Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-13-2001, 09:54 PM
Elbow
Guest
 
Posts: n/a
My battery light goes on when the car is off, and goes off when the car is on. I was told to pull the fuses out one by one and I would find out what what pulling the power, so I did that, but I had no luck. I don't really know where to go from here... does anyone have any suggestions?
Reply With Quote
  #2  
Old 03-13-2001, 10:02 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
This is a very broad subject.
The battery light should illuminate when the key is on and the engine is off. And should go out when the engine is running.

If you have problems, it could be from the alternator. The diodes control the light on the dash.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #3  
Old 03-13-2001, 10:19 PM
Elbow
Guest
 
Posts: n/a
I've just replaced the voltage regulator, and it (the battery light) started just after the new one was put in. Is that why? Why would it do that? Do you think the whole alternator needs replacing? I just got a new battery because my old one wasn't holding a charge, and it drives for a few hours just fine, so I thought that the alternator was ok... I've been spending a few hours a day this past week researching on the web, but I'm still at a loss.
Reply With Quote
  #4  
Old 03-13-2001, 10:33 PM
dieseldan's Avatar
Registered User
 
Join Date: Mar 2001
Location: Oakland Michigan
Posts: 28
Did you incorrectly connect the battery recently?
__________________
When I close my eyes, and inhale, I can smell No. 2.
Reply With Quote
  #5  
Old 03-13-2001, 11:06 PM
Elbow
Guest
 
Posts: n/a
Yes, the other day, on the morning that the voltage regulator was replaced, the battery was connected backwards... We drove about 5 minutes to where we replaced the v.r. and I didn't notice anything different then, but as soon as the v.r. was put in I noticed the battery light acting funny, and my stereo stopped working.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problems 1987 560 sel American28 Tech Help 1 06-07-2004 12:57 PM
Electrical Problems WaveRunr Tech Help 1 03-02-2004 07:31 PM
Need help with 560SL electrical problems Solarlady SL Forum 3 10-02-2003 02:17 AM
1995 C280 Electrical Problems David C Klasse Tech Help 14 04-14-2003 09:31 PM
1999 E300D Electrical Problems searaypaul Diesel Discussion 11 05-10-2002 06:52 PM



All times are GMT -4. The time now is 12:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page