Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-12-2006, 05:53 PM
Registered User
 
Join Date: Feb 2005
Posts: 116
300 E ABS light

Hi,

I have a 1987 300 E and the Antilock light comes on pretty often now. When this happens the car's idling drops about 200 rpm. Also when i am driving sometimes the light goes on and off also causing the o2 sensor light to flash, and i can tell a slight shudder in the car corresponding to the flashing.
Any suggestions?
Thanks

Reply With Quote
  #2  
Old 04-12-2006, 06:49 PM
Registered User
 
Join Date: Mar 2006
Posts: 40
my car did the same thing and I have a 92 300E. I checked the fuse on the relay behind the baterry of the car and the fuse was blown. I replaced it and the problem was solved. Check that relay and make shure the fuse is good....if it is, check the contact point on it, they might get a little dirty and not make any contact.
Reply With Quote
  #3  
Old 04-13-2006, 02:12 AM
Registered User
 
Join Date: Feb 2005
Posts: 116
Thank you for the reply. I will try your sugestion.
Reply With Quote
  #4  
Old 04-13-2006, 04:31 PM
Registered User
 
Join Date: Feb 2005
Posts: 116
Does anybody know which one the relay is mentioned above, what does it look like and how do i check the fuse (how do i open it). Thanks.
Reply With Quote
  #5  
Old 04-13-2006, 05:13 PM
Mike Murrell's Avatar
Registered User
 
Join Date: Feb 2000
Posts: 2,574
The part in question is referred to as an OVP - over voltage protection relay.

It will have either 1 or 2, 10 amp blade fuses in the top. A photo of what they look like is at the URL below. In general, it's at the very back along the false firewall. Your fuse(s) may be blown. If so, replace fuse. If not and you are seeing an ABS light, the OVP will need to be replaced. I'm using another part sites photo because this site no longer shows what an OVP looks like?

http://autopartsworld.com/overload-relay_products.html
__________________
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC
"Fräulein"
Reply With Quote
  #6  
Old 04-13-2006, 07:03 PM
Registered User
 
Join Date: Feb 2005
Posts: 116
Quote:
Originally Posted by Mike Murrell
The part in question is referred to as an OVP - over voltage protection relay.

It will have either 1 or 2, 10 amp blade fuses in the top. A photo of what they look like is at the URL below. In general, it's at the very back along the false firewall. Your fuse(s) may be blown. If so, replace fuse. If not and you are seeing an ABS light, the OVP will need to be replaced. I'm using another part sites photo because this site no longer shows what an OVP looks like?

http://autopartsworld.com/overload-relay_products.html
Thank you very much.
Reply With Quote
  #7  
Old 04-14-2006, 05:59 PM
Registered User
 
Join Date: Feb 2005
Posts: 116
Quote:
Originally Posted by benzman2
Thank you very much.
And thank you removing the ovp and cleaning contacts did the job.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page