Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-12-2006, 10:32 PM
Registered User
 
Join Date: Apr 2006
Posts: 2
Angry new valve body, tcu etc...now stuck in park??

Hi, my 97 E420 was having tranny problems and it turned out to be the common problem of fluid seeping into the TCM. I had the TCM and harness replaced and the car was stuck in limp home mode. Sooo, i took it to the MB dealer and they told me it needed a new valve body. I reluctanly plaid for the work and today they call me and tell me that it is stuck in park and I need a new shifter module.

The vehicle never had that problem before and I have never spilled anything near the shifter. My question is this: Is that problem related to the valve body repair?? I dont know if I'm getting hosed for another $1000. Any help or comments would be greatly appreciated.

Reply With Quote
  #2  
Old 04-13-2006, 08:06 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The shifter has LITTLE or nothing to do with the car stuck in PARK unless it is SEIZED completely.....! The trans is kept in park by a cable that goes into the rear of the trans & is attached to the BRAKE pedal..that is what keeps you from shifting into gear unless the brake pedal is depressed.

IF they can move the shifter with the shift linkage removed then the CABLE has to be the problem!
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 04-13-2006, 06:11 PM
Registered User
 
Join Date: Apr 2006
Posts: 2
Thanks for the info. I just wasnt sure if the work they did caused the problem and they were sticking me with the bill for something that wasnt related to the valve body exchange. thanks again.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page