Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-03-2006, 04:35 PM
Registered User
 
Join Date: May 2006
Posts: 3
1989 MB 300SE Transmission Fluid Pump

Is there a Transmission fluid pump inside the transmission? All of a sudden the Tranny fluid level is very high . It shifts into gear but won't move in forward or reverse. Any guesses on this one, Thanks.

Reply With Quote
  #2  
Old 05-03-2006, 08:31 PM
C32AMG's Avatar
Registered User
 
Join Date: Mar 2004
Location: new york/orange county
Posts: 639
If the car does not roll in park, and you have no moment forward or reverse, possibilities are no fluid in the Transmission, plug filter or a pump failure, the fluid level reading on the stick will read high with a pump failure.
If the car rolls in park , drive shaft or flex disc failure, a bad rear will gave indication of a failure, noise; an axle shaft would also make noise.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page