Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-09-2006, 09:44 PM
Registered User
 
Join Date: Jan 2006
Location: NY
Posts: 4
W220 Airmatic

I have an 02 s430 and it has the airmatic warning light on, but when you turn the car on it goes up no problem and when you press the button for the car to rise it gives no problem and goes right up and stays. (tested to see if weight on the hood would bring it down and nothing it stayed strong, brought it to a specialist and he test the seals by spraying water to see if the front was leaking but nothing, he qouted $200 for something that needed to be done. wondering after reading these forums its the relay also any ideas?
------------------------------------------------------------------------

02 S430 67k all lights upgraded to 03 plus thanks to ebay all OEM new, 20% tint all around
Reply With Quote
  #2  
Old 05-09-2006, 11:35 PM
The Workshop MB's Avatar
Mobile ASE Master MB Tech
 
Join Date: Mar 2006
Location: california
Posts: 55
you really need to have the codes pulled to see what the ecu says.
__________________
www.theworkshopmercedesbenz.com
Nahum:1.7
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page