Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-21-2006, 01:14 AM
Registered User
 
Join Date: Apr 2006
Posts: 26
500sel Idle Issue

I have a 1984 500SEL w/ 130K. When starting up it likes to idle at least a grand and sometimes 1500. When warmed up it generally stays at 1500 rpms. I have a few extra Idle control boxes i've hooked up to it without any success. I cleaned the Idle control valve with carb cleaner and wd40. Barely helped at all. Though if i disconnect the Idle control valve and reconnect it i get a really good response of under a grand to almost a perfect idle. It has new plugs, wires on it. Also sometimes on start up I have to crank it over a few extra times which I suspect that may be it needs a new fuel filter. Though it may be possible they are linked problems. Any information would be greatly appreciated. Thank you.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page