Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-21-2001, 11:42 AM
grubby
Guest
 
Posts: n/a
Dear Sir:
I am currently working on a 1974 280C. When the key is off the charge indicator light stays on and it will run the battery down over nite. I realize there are limited circuits which are live when the key is off, but do you have any ideas where to start. I was thinking about pulling off the alternator and having it checked. Any suggestions you have would be appreciated.
Thanks.
Reply With Quote
  #2  
Old 03-21-2001, 01:20 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
You probably have a bad diode in the alternator. Try disconnecting the wiring from the alternator to verify. Be sure to insulate the positive feed wire.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 03-21-2001, 07:03 PM
cth350's Avatar
Registered User
 
Join Date: Dec 2000
Location: Long Island, NY
Posts: 3,654
I just fixed the exact same problem on my 74 280c

I had a bad diode. I picked up a rebuilt distributor and swapped them. before that, I just tried swapping the voltage regulator, but it didn't help.

-CTH

PS. Be VERY careful with that positive wire. First disconnect the battery. Short that wire to ground, or have the wrench touch something and the results will be very messy.
Reply With Quote
  #4  
Old 03-27-2001, 06:04 PM
grubby
Guest
 
Posts: n/a
Dear Sirs,
Thank you for you response. I removed the alternator and the rectifier was shot. I purchased a new one and it solved the problem. Once again thank you.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical trouble; replace Alternator, Brushes or Voltage Regulator? Ducati Diesel Discussion 35 10-18-2013 10:21 PM
Question- electrical troubleshooting- oscillation temp gauge+ fuel gauge with turn ericgr SL Forum 5 09-30-2004 04:36 PM
97 E 420 Electrical Problems mmmshop Tech Help 1 07-02-2002 03:56 PM
Another electrical problem. '01 C240. Anyone heard of this? Brian K Tech Help 13 11-24-2001 05:34 PM
Anyone have an electrical schematic for a 1969 280 SEL? Thom Pintello Tech Help 3 05-20-2001 02:19 AM



All times are GMT -4. The time now is 04:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page