Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-23-2006, 08:14 PM
Registered User
 
Join Date: May 2006
Posts: 3
86 190 E idle trouble

Ok, I read thru the forumns and couldn't quite find my problem here. I've got a 2.3L 8v engine in Canada. The engine starts ok but has a nasty rattle when idleing in gear. Putting the car into neutral helps alot, I changed the plugs, just did an oil change, oh, 82k miles.

Also the local parts store didnt have any tune up parts but the plugs, what else should I be changing, and is there a decent source for parts in the Detroit/Auburn Hills area?

If someone knows a good local mechanic that would be nice too, I live currently in Windsor but bought the car for my GF, she loves her baby benz, but I'd like to get the car perfect.

Reply With Quote
  #2  
Old 05-23-2006, 10:13 PM
Battlecat714's Avatar
NEEZ FTW!
 
Join Date: Apr 2006
Location: Anaheim, CA
Posts: 339
Quote:
Originally Posted by shadow_lost
Ok, I read thru the forumns and couldn't quite find my problem here. I've got a 2.3L 8v engine in Canada. The engine starts ok but has a nasty rattle when idleing in gear. Putting the car into neutral helps alot, I changed the plugs, just did an oil change, oh, 82k miles.

Also the local parts store didnt have any tune up parts but the plugs, what else should I be changing, and is there a decent source for parts in the Detroit/Auburn Hills area?

If someone knows a good local mechanic that would be nice too, I live currently in Windsor but bought the car for my GF, she loves her baby benz, but I'd like to get the car perfect.
motor mounts?
__________________
1994|040|W124.036|E500
http://www.mbworld.org/forums/image....ine=1216527951
Reply With Quote
  #3  
Old 05-24-2006, 12:24 AM
GVB GVB is offline
Registered User
 
Join Date: May 2006
Posts: 178
You have a bad belt tentioner and tentioner dampner.
Reply With Quote
  #4  
Old 06-04-2006, 08:01 PM
Registered User
 
Join Date: May 2006
Posts: 3
Ok I feel bad but I cant find the tensioner, are we talking the ACC belt, or the timing belt? I'll go see if I can find the Haynes manual.
Reply With Quote
  #5  
Old 06-05-2006, 09:38 AM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,706
Its your motor mounts trust me and Battlecat714!

The belt tensioner for the ACC belt will not cause a rough idle it will just make a racket.
Change your motor mounts, smoother in idle and rough in gear is a classic symptom and when they are replaced it will be like a new car believe me
Reply With Quote
  #6  
Old 06-05-2006, 10:08 PM
Registered User
 
Join Date: May 2006
Posts: 3
Motor mounts I can handle already done and engine swap on my 63 'vette, so got tonnes of that hardware.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page