Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-26-2006, 09:55 PM
Registered User
 
Join Date: Nov 2004
Location: Ashland, KY
Posts: 365
'90 420sel stalls after running through water

'90 420SEL - we had LOTS of rain today and during the course of trying to get home I had to drive through about 3 inches of water. I took it slowly but when I got to the first traffic light (almost immediately after going through the water) the car started running roughly and then acted as if it would die. I pulled over and waited for an hour and the car would start and idle fine for about 30 sec. and then would start the same thing over again - bad idle as if it were missing and then would almost die. I checked the air cleaner housing to make sure I did not ingest water and I didn't. I am going back here in about an hour and try to get it home - if not then it is the dreaded tow truck. The car ran great until this happened. Any suggestions?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page