Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-22-2001, 07:56 PM
Registered User
Join Date: Jul 2000
Posts: 56
I have a euro engine 117.961. The car operates very well, normal hot and cold starts, etc. Complaint is poor mileage, getting 13.0 MPG (at best) in city over many many months. Other complaint is that idle RPM falls below normal when outside temp. hits 78 deg. + with A/C on or in slow traffic.

Odometer is accurate. Electrical side is proper from coil to plugs. Timing is set at 30 deg. BTDC @ 3000 RPM with vacuum advance plugged. CO reading at 869 RPM is 0.43%. HC is 63 PPM. (No cat.) Cam timing is dead on. System pressure is 85 bar. Control pressure is 21 bar cold and 52 bar warm. Leakdown is 44 bar after 10 min. and 42 bar after 20 min. Water temp. is in 80 to 90 deg C. range. Rebuilt fuel distributor, no internal leaks. All injectors have good spray, no leaks. Cold start valve does not leak.

I recently diagnosed that vacuum advance diaphram was faulty. Bought new one through PartsShop and thought this was going to be the cure. Unfortunately not.

Pressure tests do not seem to suggest problems with warm up regulator or fuel pressure dash pot. Any suggestions besides just living with the problem?
Reply With Quote
Old 03-22-2001, 08:34 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Try a bit more timing, 34deg total should help. Also running just a bit richer .50-.75% co. US 500SEL's were EPA rated at 14mpg city.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
VERY basic coolant questions mradowic Tech Help 3 05-13-2002 07:34 AM
Basic questions about upgrading '92 190E system Ross Car Audio and Multimedia 1 06-14-2001 05:35 PM
Basic questions David K Tech Help 6 04-17-2001 07:07 PM
Cooling system questions 96 E 320 CarrMcCormack Tech Help 3 01-28-2001 04:04 PM
A few questions about the fuel system in 86 300E. pezzy Tech Help 1 11-21-2000 09:47 PM

All times are GMT -4. The time now is 05:24 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page