Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-29-2006, 02:35 PM
Registered User
 
Join Date: Mar 2005
Posts: 43
Problem with power window-300TE

I have a 1989 300te wagon. Power front passenger window is not working and is unfortunately stuck in the down position. I had the regulator replaced about 1.5 years ago. Fuse is ok. Any thoughts? Thanks, Jay.

__________________
1989 300TE
Reply With Quote
  #2  
Old 05-29-2006, 05:03 PM
Battlecat714's Avatar
NEEZ FTW!
 
Join Date: Apr 2006
Location: Anaheim, CA
Posts: 339
Quote:
Originally Posted by taker22
I have a 1989 300te wagon. Power front passenger window is not working and is unfortunately stuck in the down position. I had the regulator replaced about 1.5 years ago. Fuse is ok. Any thoughts? Thanks, Jay.
Is there something obstructing the tracks?
__________________
1994|040|W124.036|E500
http://www.mbworld.org/forums/image....ine=1216527951
Reply With Quote
  #3  
Old 05-29-2006, 05:47 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Does the motor make a sound in the door when trying to use the switch? If not it could simply be a dirty switch.

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #4  
Old 05-30-2006, 01:58 PM
Registered User
 
Join Date: Apr 2002
Location: westchester, ny
Posts: 747
with KOEOff, hit the window motor lightly with a hammer while someone holds down the switch. Recommended by my indy, and it worked for me.
__________________
87 300e (white/black; amg body kit)
88 300ce (red/cream; amg body kit)
93 300ce cabrio (white/blue/blue top)
93 300ce cabrio (black/grey/black top)
98 ml 320 (totaled @ 137,000 miles)
99 clk320 (black/grey/black top)
Reply With Quote
  #5  
Old 05-30-2006, 03:48 PM
tvpierce's Avatar
Registered User
 
Join Date: Feb 2002
Location: Portland, ME
Posts: 612
Try swapping the switch from the rear window on that side. If that works, then you know you need to order a new switch.

Jeff Pierce
__________________
Jeff Pierce

Current Vehicles:
'92 Mercedes 190E/2.3 (247K miles/my daily driver)
'93 Volvo 940 Turbo Wagon (263K miles/a family truckster with spunk)
'99 Kawasaki Concours
Gravely 8120
Previous Vehicles:
'85 Jeep CJ-7 w/ Fisher plow (226K miles)'93 Volvo 940 Turbo Wagon
'53 Willys-Overland Pickup
'85 Honda 750F Interceptor
'93 Nissan Quest
'89 Toyota Camry Wagon
'89 Dodge Raider
'81 Honda CB 750F Super Sport
'88 Toyota Celica
'95 Toyota Tacoma
'74 Honda CB 550F
Reply With Quote
  #6  
Old 05-30-2006, 06:49 PM
Fourings's Avatar
It was her idea.
 
Join Date: Nov 2002
Location: Denver for now
Posts: 76
It is unlikely you have this problem, but when I bought my TE the front passenger window didn't work. After replacing the switch with no luck I wound up taking the door apart and finding that one of the arms the regulator had become wedged between the motor and another part of the regulator. Seems someone had taken the whole thing apart once before and left out a bushing that would've prevented that from happening.
Like I said, it is likely the switch or perhaps the motor (less likely), but before going and buying a new regulator be sure to exhaust all possibilities.
__________________
Fourings

84 Audi Coupe GT with Turbo engine, EFI (buh-bye CIS), Jamex seats, Koni's/H&R's, e-code lights. 210k and counting.
1992 Anthracite 400E, 161k, "Grey Ghost".
1986 VW Quantum Syncro, 192k, gone to the crusher in the sky.
1989 300TE 172k. (Was mine, now also Mom's car)
72 280SE 4.5 (Mom's car)
Reply With Quote
  #7  
Old 05-30-2006, 07:30 PM
Registered User
 
Join Date: Mar 2005
Posts: 43
Smile

Quote:
Originally Posted by richard28
with KOEOff, hit the window motor lightly with a hammer while someone holds down the switch. Recommended by my indy, and it worked for me.
Richard- not sure where window motor is but after banging on the inside of the door with my hand a buch of times the window started working again. Jay
__________________
1989 300TE
Reply With Quote
  #8  
Old 05-31-2006, 05:12 AM
Gerard's Avatar
91 300CE M103: 80 450SEL
 
Join Date: Nov 2001
Location: Dublin, Ireland
Posts: 112
Open the door?

Try opening the drivers door and see if the window will work. There are some switches in the door, maybe the problem is in that circuit?
Gerard

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page