Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-22-2001, 11:57 PM
Registered User
Join Date: Dec 2000
Location: ny
Posts: 119
wrecked my pearl white 500sec last saturday so today i pulled out the blue euro 500sec i really wanted.after starting it and letting it warm up i put it in gear to pull out and the trans took a minute or two to go into gear(actually had to gas it a bit to engage)is there an adjustment that can be madeor is the trans going bad?any help would be appreciated as this is a major factor in the price of the performs fine otherwise trans does not slip or flair or nuetralize

[Edited by 500sec on 03-23-2001 at 12:08 AM]
Reply With Quote
Old 03-23-2001, 04:38 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
There is a check valve in the valve body to keep fluid in the torque converter, sounds like this is allowing fluid bleed-off(back) into the trans pan.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 500SL ASR Problem jrodnar SL Forum 10 12-22-2008 11:18 AM
560 sec sunroof liner problem zr one Tech Help 1 09-09-2002 01:15 PM
REAR WHEEL PROBLEM ON SEC thomas jenkins Tech Help 1 01-28-2001 07:44 PM
Chapter 2 S Class Trans Problem Magred Tech Help 1 01-06-2001 08:52 PM
560 sec sunroof problem aandressoo Tech Help 2 02-29-2000 03:24 PM

All times are GMT -4. The time now is 05:22 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page