Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-31-2006, 01:01 PM
Glen's Avatar
...auto enthusiast
 
Join Date: Sep 2000
Location: Carlsbad, CA USA
Posts: 1,187
W210 fan speed won't change?

My sis-in-law has a 1997 W210 E420. Recently, the cabin fan began acting up. The A/C blows cold air, however, the fan only blows at the lowest speed. In auto mode, the display indicates that the fan should go higher, but it doesn't. In manual mode, same thing, the fan stays at the lowest speed.

Any ideas?

Thanks!

__________________
Glen Tokuhara
Beauty & the Beast and the wagon that could!
Reply With Quote
  #2  
Old 05-31-2006, 01:16 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
Bad regulator, probably.

I'm not sure when the change was made, but the regulator and blower motor were updated. If you have the earlier type (I think it's likely), you are supposed to change both of them if either fails.

However, I do recall reading about a way to modify a certain 140 blower motor regulator to work with the old-style 210 blower. Try searching for such things.
Reply With Quote
  #3  
Old 05-31-2006, 04:08 PM
Glen's Avatar
...auto enthusiast
 
Join Date: Sep 2000
Location: Carlsbad, CA USA
Posts: 1,187
Thanks Matt. I'll do some searching...
Reply With Quote
  #4  
Old 06-01-2006, 04:37 PM
Registered User
 
Join Date: Dec 2005
Location: Atlanta.
Posts: 366
I would stay away from the mod, and go with the new blower motor and regulator fix.
Reply With Quote
  #5  
Old 06-01-2006, 05:46 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
I'd prefer to do that, but then you're talking about a whole bunch of money.
Reply With Quote
  #6  
Old 06-01-2006, 06:18 PM
Glen's Avatar
...auto enthusiast
 
Join Date: Sep 2000
Location: Carlsbad, CA USA
Posts: 1,187
The modified W140 regulator seems like a good option, why would it not be a good idea?
Reply With Quote
  #7  
Old 06-01-2006, 07:28 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
Only because it's not an MB approved fit. But not everything I do is MB approved.
Reply With Quote
  #8  
Old 06-01-2006, 07:39 PM
Glen's Avatar
...auto enthusiast
 
Join Date: Sep 2000
Location: Carlsbad, CA USA
Posts: 1,187
I see. FWIW, the repair shop that my sis-in-law contacted recommended against the W140 regulator. Instead, they believe they can source an old-style W210 regulator. I'll follow-up with more later...
Reply With Quote
  #9  
Old 06-01-2006, 08:22 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Quote:
Originally Posted by Glen
I see. FWIW, the repair shop that my sis-in-law contacted recommended against the W140 regulator. Instead, they believe they can source an old-style W210 regulator. I'll follow-up with more later...

Why would you want the old style regulator.. they would not take the current demands.. which is why guys replace them with the 140 unit conversion..

http://www.peachparts.com/Wikka/W140BlowerMotor
Reply With Quote
  #10  
Old 06-02-2006, 02:47 AM
georgedaman
Guest
 
Posts: n/a
I had the same problem awhile back,same car same year.The regulator is under the glowebox and it cost 250 canadian dollars at the time.It did it for me.
Reply With Quote
  #11  
Old 06-05-2006, 12:01 PM
Glen's Avatar
...auto enthusiast
 
Join Date: Sep 2000
Location: Carlsbad, CA USA
Posts: 1,187
Quote:
Originally Posted by Arthur Dalton
Why would you want the old style regulator.. they would not take the current demands.. which is why guys replace them with the 140 unit conversion..

http://www.peachparts.com/Wikka/W140BlowerMotor
Thanks Arthur. If it were me, I'd go with the 140 unit. I'll pass along this info.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page