Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-02-2006, 06:14 PM
Befuddled
 
Join Date: Jun 2006
Location: Oregon
Posts: 8
Chattering ABS system

I have a 1989 300E. Everything seems to work okay on the brakes except that it chatters sometimes when coming to a stop. I had it diagnosed at the local MB dealer and they charged me a fee and told me it was the sensors. I replaced them but it still chatters.

My daughter had a Mercedes Benz mechanic replace an alternator when she was on vacation (another story). When asked about the brakes he told my daughter that it was a solenoid that needed replacing. I looked it up and found there are two. Where are they located on the car and is this the fix?

Thanks,

Jim Marshall

Reply With Quote
  #2  
Old 06-02-2006, 06:40 PM
jhodg5ck's Avatar
Registered User
 
Join Date: Feb 2004
Location: Atlanta, GA
Posts: 1,405
could be the sensor on the diff.. Could be that the computer is having difficulties as well.. In the mean time I would up-plug that ABS computer as having malfunctioning ABS IMO is worse then no ABS at all..

Jonathan
__________________
Blue Ridge Mercedes
Jonathan Hodgman
http://www.blueridgemb.com/
Enthusiast Service, Restoration & Tuning.
Follow Us on Facebook!
Located in the Atlanta area
Specializing in all pre and post merger AMG's including Hammers and DOHC M117 engines.
Mercedes Repair Atlanta
Reply With Quote
  #3  
Old 06-24-2006, 10:59 AM
Befuddled
 
Join Date: Jun 2006
Location: Oregon
Posts: 8
Chattering Brakes

The Local Mercedes dealer charged me $65 to diagnose the problem as a sensor. I replaced both but it wasn't the problem. He also didn't say anything about a noisy water pump until I told him about it. Some mechanic.

I was also told by another mechanic that there are two abs solenoids that are located behind the battery and he says he thought that was the problem.

Jim
Reply With Quote
  #4  
Old 06-24-2006, 09:52 PM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,707
How about the third sensor in the back?
Reply With Quote
  #5  
Old 07-02-2006, 12:08 PM
Befuddled
 
Join Date: Jun 2006
Location: Oregon
Posts: 8
It feels like it is coming from the front.

Jim
Reply With Quote
  #6  
Old 07-07-2006, 04:27 AM
Registered User
 
Join Date: Jun 2006
Location: Geelong, victoria Australia
Posts: 16
Exclamation Chattering brakes

Agree with others, but have your pads, calipers, rotors and [B]brake fluid been checked to c if they are to specs???? No good fiddling with the ABS's CU if these items are not up to the job.

If you read the manual, u can c that it is normal and acceptable for some 'shudder' to occur under the 'pick up speed' of the ABS's CU (Control unit), it will appear to come from the front as thats whats happening. The pads are making/breaking contact with the rotors at this speed and the CU is not yet engagued. Usually not up untill about 10Kph.

If you r having shuddering or chattering problems @ speed , best check the calipers, and all above, as well as worn/unservicable steering/chassis components

Have fun, keep in touch,
Graham
Reply With Quote
  #7  
Old 08-01-2006, 03:26 AM
Registered User
 
Join Date: Feb 2003
Location: UK - South East Coast
Posts: 864
Did you ever resolve this chattering issue? As I have exactly the same issue - ABS coming on - over sensitive!

Cheers
Lea
__________________
'93 R129 500SL-32
'89 190E 2.6 - sold in 2002

http://antron.pwp.blueyonder.co.uk/i...nature/Sig.jpg
Reply With Quote
  #8  
Old 08-08-2006, 04:30 PM
Registered User
 
Join Date: Feb 2003
Location: UK - South East Coast
Posts: 864
My issue is resolved - it was the cracked toothed sensor rings.

Replaced both front rings and all is now OK.

__________________
'93 R129 500SL-32
'89 190E 2.6 - sold in 2002

http://antron.pwp.blueyonder.co.uk/i...nature/Sig.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page