Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-02-2006, 07:22 PM
Pete Geither's Avatar
Half Fast Moderator
 
Join Date: Feb 2002
Location: Western Pa.
Posts: 2,417
New code on the TE

What in the hell does this mean ?
4 Air injection system faulty hot film mass air flow sensor with hot wire.
CE lite came on today and I naturally thought it was the code 5,,, EGR, which I have been resetting for years. This is what showed up and the CE lite didn't reset. Where do I go from here ?

__________________
95 SL500 Smoke Silver, Parchment 64K
07 E350 4matic Station Wagon White 34K
02 E320 4Matic Silver/grey 80K
05 F150 Silver 44K
Reply With Quote
  #2  
Old 06-02-2006, 09:07 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Does the AIR pump come on???????/
Reply With Quote
  #3  
Old 06-02-2006, 09:15 PM
Pete Geither's Avatar
Half Fast Moderator
 
Join Date: Feb 2002
Location: Western Pa.
Posts: 2,417
Air pump Who knows,,,, I fix a number of things, but air pumps ? I sincerely thank you Arthur,,, you always bail me out, but you are going to have to lead me through this one too.
__________________
95 SL500 Smoke Silver, Parchment 64K
07 E350 4matic Station Wagon White 34K
02 E320 4Matic Silver/grey 80K
05 F150 Silver 44K
Reply With Quote
  #4  
Old 06-02-2006, 09:36 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
AIR code [4] is common malfaunction of the AIR Injection System on HFM/104s...
This is an emissions related code , as the AIR is called upon to heat the cat rapidly at cold start to get the car into closed loop as fast as possible .

So, when diagnosing,we seperate the system into 2 catagories... one is electrical and the other is vac/air system.
If the pump comes ON at start-up, we do not have an electrical feed problem ..So we go into the air passage system.
But , if the pump does not come on , we start with 'Why not?'
First check is fuse.
If the pump does come on, then the first suspect on that model is the white plastic vac line running across the front of the engine , over to the EGR and AIR Switch-Over-Vaves. They crack/fatique from engine heat and shouild be replaced with a full rubber line.
**This line is COMMON vac feed for BOTH EGR and AIR SOVs , so it may well also be your EGR code cause !! When these two codes come up, this line is first suspect......
The next suspect is the SOV and check valve, but check the above first so I don't load your plate up all at once.

Last edited by Arthur Dalton; 06-02-2006 at 09:52 PM.
Reply With Quote
  #5  
Old 06-03-2006, 05:24 AM
Pete Geither's Avatar
Half Fast Moderator
 
Join Date: Feb 2002
Location: Western Pa.
Posts: 2,417
Thanks a ton as usual Arthur. I am heading out this morning for a little getaway in the SL, so the TE will have to wait for a few days. Will check back in, in about a week. Thanks again !!

__________________
95 SL500 Smoke Silver, Parchment 64K
07 E350 4matic Station Wagon White 34K
02 E320 4Matic Silver/grey 80K
05 F150 Silver 44K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page