Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-03-2006, 10:22 PM
Registered User
 
Join Date: May 1999
Location: Lexington, Ky
Posts: 3
91 300E Poor Mileage

I have a 91 300E which I recently had the heads rebuilt on due to oil consumption. Prior to the work my mileage was 20 - 22. After it has dropped to 15-17. Sent it back to the shop and they adjusted the lamda (sp) control to increase the vacum. My economy gage now runs in the middle even at idle.

Any thoughts would be appreciated.

Clark

__________________
Long Time MB Owner
1971 250C
1987 260E
1983 380 SEC
Reply With Quote
  #2  
Old 06-04-2006, 02:55 PM
Registered User
 
Join Date: Feb 2006
Location: Jasper, TX
Posts: 31
Red face

Sounds much like a vacuum line is off. Remove the air cleaner and check the lines underneath and where they connect to the intake manifold. Might be a starting point.
Good luck.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page