Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-19-2006, 03:52 AM
Registered User
 
Join Date: Oct 2001
Location: USA
Posts: 102
190E Die @ Idle sometimes when stopping the car

Dear All,
I just got my 2.5-16V and i got a question.
The car start and run fine. But sometimes when i need to stop the car (say before the traffic light) the idle sometimes is stable (1100rpm=> 950rpm)
sometimes drop to 650rpm then jump back to 1100rpm then 950rpm
a few times drop to 500rpm and the engine die............. then i need to restart again.


anyone experienced such problem?
will the fuel injection cleaner may help to sove the problem?

THx

Reply With Quote
  #2  
Old 06-19-2006, 02:42 PM
Registered User
 
Join Date: May 2005
Posts: 84
I found my 190e had a vacuum leak at the idle stabilizer motor hose, it was causing same type of problems. with the car idling hot just push and pull on the hose, if its bad the car will stall. also check for other vacuum leaks.
joe
Reply With Quote
  #3  
Old 06-19-2006, 09:25 PM
mad1's Avatar
Registered User
 
Join Date: Jun 2006
Location: Toronto, Canada
Posts: 59
Could be your engine mounts. I believe one symptom of failing engine mounts is stalling when coming to a stop from freeway speeds
Reply With Quote
  #4  
Old 06-19-2006, 09:44 PM
hornbrod's Avatar
Registered User
 
Join Date: Mar 2004
Location: North Alabama
Posts: 67
Probably a sticking and/or inop idle control valve. Pull the idle control valve (ICV) and clean it out with carb cleaner, and check the inlet and outlet hoses; they tend to get brittle and hard with age and can leak. While you have the ICV out, apply 12V to it and make sure it operates - you should hear a loud click. Common problem with these cars.
__________________
93 190E Sportline (RIP) (45K)
92 190E (Xferred most Sportline parts to this body)
88 300CE (71K)

And the Jeeps:
01 2WD Cherokee XJ (35K, Mama's grocery/kid hauler)
91 4WD Comanche (300HP stroker)
Reply With Quote
  #5  
Old 06-19-2006, 11:39 PM
Registered User
 
Join Date: Oct 2001
Location: USA
Posts: 102
thx guys
i have replaced the engine mount.
I will check the ICV and the vaccum hose, and will try to clean the system too.
hope the problem will be gone.

it only happened a few time, only when before coming to a stop light.....esp after rev the engine
Reply With Quote
  #6  
Old 06-20-2006, 01:29 PM
Registered User
 
Join Date: Oct 2001
Location: USA
Posts: 102
here is an update for my 2.5

I try to clean the air mass (the one under the air filter) today. but i dont think it help.

When start the car, the rpm will bounce from 1100 then 650 then 1000 then 900 and stable at 950rpm.

THen the car runs very well.....

After I parked the car for an hr for dinner, then I come back and restart the car. The rpm seems a little funny. when I shift to first gear, the car seems not very welling to move only at the beginning. after the car runs, everything is fine.

Then I drive for another 20 mins, everything is fine, then I stop the car outside 7-11 and buy a drink then return to the car... the car start. I was playing the clutch then i see the rpm drop to 650rpm and then the car died.

I restart the car, the rpm stay at 1100rpm, then I apply the clutch again, the rpm drop again til the car die again.

Then i restart the car and drive, the car is running ok.... then i come to the first traffic light, i step on the clutch and then the car die again. Before i stop, the engine did rev til 3500rpm. i just found out if i shift before 3000rpm, it car wont die when i stopping the car. if rev over 3500rpm, the car may die....

Next test, i try to step on the gas, run at second gear, let the engine run til 4ooorpm, then step on the clutch, i can see the rpm drop... then til 650rpm then bounce back to 950rpm.

I really dont know what is going wrong, anyone can give me any suggestion?
thx
Reply With Quote
  #7  
Old 06-20-2006, 01:37 PM
Registered User
 
Join Date: Oct 2001
Location: USA
Posts: 102
my friend ask me to replace this tube also, he said the vaccum may be leaking... (attach photo)

is there any other tube i should be replace too?

is there any area i should beware too?

Thx!!
Attached Thumbnails
190E Die @ Idle sometimes when stopping the car-tn_ssl20065.jpg  

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page