Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-31-2001, 05:51 AM
Registered User
 
Join Date: Dec 2000
Location: Concord, CA
Posts: 27
Symptom:

Most of the time, when I start my '88 TE, all is well with my climate control unit. Specifically, when I push the top most fan speed button, it really blows a lot of air around. Lately, when I start the car and do the same as above, sometimes nothing happens. Pushing any of the other AC buttons on the left, even the max defrost, makes no difference. Further, I have found that when I get no response from the fan speed button and the rest of the climate control unit, I can restart the car and all is back to normal.

Question: Is it time to R/R the Climate Control unit?

Many Thanx.
__________________
Al D.
1988 300TE
Anthracite/Grey MB Tex
205/55/16, 16x7.5 Lorinser 15-hole
'95 S-500 corners
50% tint all windows
Kleen Wheels
Reply With Quote
  #2  
Old 03-31-2001, 07:43 PM
JCE's Avatar
JCE JCE is offline
Down to the Wear Bars
 
Join Date: May 1999
Location: So Kalifornia
Posts: 2,189
For what it is worth, intermittent AC on past posts has often been the AC relay or Aux water pump. Start checking the least expensive items before doing a whole AC or control unit r+r, in my opinion. Also, past posts talk about how to temporarily bypass the klima relay to check for problems. Good luck!
__________________
John

2003 Firemist Red/grey leather SL 500
2015 Palladium Silver/black mbtex GLK 350
1987 Smoke Silver/burgundy mbtex 300E Sportline (SOLD)

Click to see 87 300E
Reply With Quote
  #3  
Old 04-01-2001, 02:29 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
You may want to check your mono belt. If it is loose, that may fool you AC system...
__________________
J.H.
'86 300E
Reply With Quote
  #4  
Old 04-01-2001, 02:50 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
It sounds like a blower problem from your symptoms. I would check the large blade fuse. I don't remember whether 124 cars have the ignition switch problem that the 126 cars did, but I would wiggle the key next time it occurs.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #5  
Old 04-06-2001, 07:33 PM
Registered User
 
Join Date: Dec 2000
Location: Concord, CA
Posts: 27
works sometimes 124 climate control

Steve,

Thanks for the free-bee. The solution is exactly as you prescribed...just wiggle the key!

Going forward, when it comes time for the ignition switch to be replaced (like I did with my earlier 190E) will the replacement solve this challenge for good, or is there something else that I need to address while it's being worked on?

Thanx much.
__________________
Al D.
1988 300TE
Anthracite/Grey MB Tex
205/55/16, 16x7.5 Lorinser 15-hole
'95 S-500 corners
50% tint all windows
Kleen Wheels
Reply With Quote
  #6  
Old 04-06-2001, 07:53 PM
Registered User
 
Join Date: Apr 2000
Posts: 530
Same happened to mine. Just need to replace the electrical portion of the ignition or wiggle the key. Goes away once repaired.
__________________
1988 Mercedes-Benz 260E
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
300SDL climate control turbodiesel Diesel Discussion 12 01-07-2003 11:00 AM
"Another" Climate Control question.... rwthomas1 Diesel Discussion 4 12-04-2002 07:13 PM
Climate control unit '88 260E robbysf Tech Help 1 09-16-2002 01:39 PM
Climate Control Panel & Cruise Control rmmagow Diesel Discussion 3 07-17-2002 09:40 PM
Climate control Problems...Need help Maddog Tech Help 8 07-17-2002 06:29 PM



All times are GMT -4. The time now is 08:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page