Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-19-2006, 05:28 PM
wjm's Avatar
wjm wjm is offline
Statman
 
Join Date: Dec 2000
Location: Suburban Detroit, MI
Posts: 692
94 E420 - Turn Signals / Blinkers

Folks,

My 94 E420 Turn Signals are acting erratically on an intermittent basis.

When I need to use them.. they don't always come on. Sometimes I'll turn them on... they'll blink for a bit... then stop. Other times, they don't come on at all. Sometimes, like yesterday evening, they were not problem.

Any recommendations on where I should start looking?

Thanks in advance!!
================================
E420 - W124 - 124 - 94 - 194 - blinkers
Reply With Quote
  #2  
Old 07-19-2006, 06:29 PM
Battlecat714's Avatar
NEEZ FTW!
 
Join Date: Apr 2006
Location: Anaheim, CA
Posts: 339
have you recenlty installed a bulb? Sometimes what the electronics will do is act erratically if there is an incorrect bulb or it could be a simple fuse issue.
__________________
1994|040|W124.036|E500
http://www.mbworld.org/forums/image....ine=1216527951
Reply With Quote
  #3  
Old 07-19-2006, 06:55 PM
skiier3_9's Avatar
Registered User
 
Join Date: Jan 2005
Location: Minnesota
Posts: 975
Could be a bad combination switch (on the steering column) - how does the high beam switch and or the wiper work? Intermittent or no problems?

I would also check out the combination relay - have someone see if your brake lights are on when the turn signals aren't functioning.
__________________
Daily Driver: 02 E430 4MATIC
In the family: '03 E500 // '04 ML500 // 64 220SE
Reply With Quote
  #4  
Old 07-19-2006, 10:48 PM
wjm's Avatar
wjm wjm is offline
Statman
 
Join Date: Dec 2000
Location: Suburban Detroit, MI
Posts: 692
I now thinks it's the relay. When the blinkers don't work, neither do the hazards nor the intermittent wipers. I opened the hood and tapped on the relay box when this happens, and it comes back on.

Just ordered one here for about $67 total with shipping.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page