Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-07-2001, 03:18 AM
ewolf
Guest
 
Posts: n/a
In recent days I heard sounds like sloshing H2o coming from underneath my dash. Now my A/C will not work in cooling mode. Works fine in heat, blower works fine. Fuses look ok.
Any suggestions?

Thank you
Reply With Quote
  #2  
Old 04-07-2001, 11:47 AM
Registered User
 
Join Date: Jun 2000
Location: Dubai, United Arab Emirates
Posts: 238
...generally, a sloshing sound under the dash means the condensed water from the condensor is not draining from the heat exchanger, take a look and make sure the drain is clear and the the water can find it's way overboard . . .
__________________
1993 190E 2.0L (Euro.) sold
1991. 500 SEL (Euro.)
1991. 300 CE (Euro.) sold
1993. 500 E (U.S. spec.)
Reply With Quote
  #3  
Old 04-07-2001, 11:56 AM
steve hutson
Guest
 
Posts: n/a
I had the same sound in my dash. It turned out to be air in my heater core which was fixed by bleeding the cooling system. If you aren't getting any cold air, check to see if your compressor is turning, get a friend to sit in the car while you look at the front of the compressor. when he or she pushes the a/c/ button, you will hear a "clack" sound as the compressor clutch engages. The car is running, of course. There are lots of causes for no cooling as I found out this week, but that one is a first step. Good luck.
Reply With Quote
  #4  
Old 04-07-2001, 11:48 PM
Registered User
 
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
How do you know the AC is working in heat mode? If you have water in the evaporator chamber, it will decrease air flow or possibly freeze,, if the AC is working. You need to start under the hood as advised. Check compressor function, check low pressure line for temp drop, check sight glass for bubbles. Work from the front to the back. The drains are located above the tranny near the bellhousing. Rubber flapper hoses. Will probably need the roto-rooter treatment with pipe cleaners or soft wire.
__________________
Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE
No matter what you fix, there will always be something else to fix..
"Warranty" is just another way of postponing the inevitable.
Reply With Quote
  #5  
Old 04-08-2001, 01:47 AM
ewolf
Guest
 
Posts: n/a
Thank's for all the info. Compressor is working. Today the A/C put out cold air. Still have the H2O sound though. Will try to find the drains and look at that.
Thanks again to all.
Reply With Quote
  #6  
Old 04-13-2001, 09:26 PM
ewolf
Guest
 
Posts: n/a
Problems fixed

Turned out all the car needed was a new charge of Freon. Had some dye injected at the same time just to make sure there are no leaks.
Total cost $200, expensive but the end result was worth it.

Thanks for everyones help.

Eric
Reply With Quote
  #7  
Old 04-13-2001, 10:02 PM
Registered User
 
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
The R-12 charge took care of the ocean noises. That's interesting..
__________________
Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE
No matter what you fix, there will always be something else to fix..
"Warranty" is just another way of postponing the inevitable.
Reply With Quote
  #8  
Old 04-14-2001, 12:37 AM
ewolf
Guest
 
Posts: n/a
Yes Jeff, it caught me by surprise also. Guess I lucked out (for once)

Later,
Eric
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Return of idle problems - '91 190E 2.3 sbourg Tech Help 11 05-19-2003 11:25 AM
95s 320 problems are they common?AC/LOCKING system/head gasket leaks joe cantalino Tech Help 0 05-14-2003 11:00 PM
300CE strange idle behavior DMITRY Tech Help 0 01-14-2002 12:50 PM
1986 300E - 3n ew problems after service olivo880 Tech Help 3 10-31-2001 12:18 AM
Cruise Problems on 300CE PhilT Tech Help 1 08-16-1999 11:08 PM



All times are GMT -4. The time now is 07:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page