Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-12-2001, 10:50 PM
Larry R
Join Date: Feb 2001
Location: Oklahoma
Posts: 20
Still looking for help on my dash lights. I removed the speedo cable and put the panel back in. The dash lights only don't work. The lights for the heater and shift and outside temp still work. I took it back and checked all connections and put it back then it worked. When I received the new cable and put it in they don't work again. This has happened twice in the past but they just came back on. Anyone know what component would be causing this. I also replaced the bulbs when I had it out.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
dash lights 1,2 & 4 are out on w124 richard28 Tech Help 8 10-14-2003 10:06 AM
better lights in the dash eplack Diesel Discussion 2 04-04-2003 12:31 AM
1990 190E Climate Control Dash lights not working JDUB Tech Help 1 02-16-2003 11:39 AM
wanted euro lights for 1985 190e headlights indacators and rear lights scrapdog045 Mercedes Used Parts For Sale & Wanted 0 05-10-2002 12:27 AM
Dash Lights And Glowplugs BLUEFOOT Diesel Discussion 0 03-11-2002 08:34 PM

All times are GMT -4. The time now is 04:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page