Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-19-2001, 09:32 PM
Posts: n/a
Have been having intermittent problem with late upshifts. First noticed no 3-4 upshift till extremely high speed. When this happens, 2-3 shift is late, can be shifted by lifting throttle above about 40MPH. Cable adjustment has some effect, but when operation becomes normal, cable seems to have normal effect on operation, that is, small movements of adjustment make corresponding changes in shift points. This problem will sometimes come and go within a driving cycle, or remain for a couple of days. When things are normal, operation is flawless-no slow or slipping shifts, even under full throttle. Anyone had this happen?? Thanks....Pat
Reply With Quote
Old 04-20-2001, 02:01 PM
Registered User
Join Date: Oct 1999
Location: New York City Burbs
Posts: 177
Id start by chnaging the tranny fluid and filter. See if it improves any. Id also guess that time and mileage is catching up with your tranny. But on the other hand , there is a Benz taxi in my town , and that car has 500k miles and the driver swears that the original trannny is in there. (its a diesel)

good luck,
Patrick Leber
'84 190E 2.3
'83 Porsche 944 (track car)
'84 Porsche 944 (parts car)
85.5 Porsche 944 (sled)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
6.9 transmission - no kickdown & early upshifts mapab Vintage Mercedes 4 05-04-2003 01:31 PM
ASR problems on1991 560sec TJM Tech Help 1 04-10-2003 06:54 PM
1992 500e /1987 560sec for sale zr one Mercedes Cars For Sale 6 01-28-2003 10:06 PM
What other MB wheels can I put on a 560SEC benjylafond Wheels & Tires 1 11-27-2002 02:28 AM
560sec, can I replace OEM fuel pumps with electirc aftermarket? mike Tech Help 2 06-29-2002 11:24 PM

All times are GMT -4. The time now is 01:58 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page