Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-24-2001, 10:08 AM
Posts: n/a
1993 300E2.8, 66K miles. When the air conditioner compressor turns on at idle, there is a slight knocking/clicking/pinging sound that almost sounds like ignition knock. Not too loud--you can only here it with the window down. As soon as the a/c compressor turns off, everything is quiet. Also, with a slight increase in engine speed, the sound goes away even with a/c on. I have never heard it at normal driving rpms, just at idle. Any ideas on what it could be?
Reply With Quote
Old 04-24-2001, 03:29 PM
J.HIDALGO's Avatar
Registered User
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
It sounds like you AC compressor/clutch is making that sound...
'86 300E
Reply With Quote
Old 05-07-2001, 10:43 AM
Posts: n/a
Ever figure out what it was? I just installed a brand new compressor in my 300D and had it converted to R134a. I also installed a new belt for the compressor while I was at it. I experience the same knocking sound, but only at idle (~700RPM). If I increase engine speed to close to 1000RPM, the sound promptly goes away. It's annoying and somewhat embarassing, but I suppose I can live with it.. the A/C is nice and cold. The sound goes away as soon as I turn off the compressor.
Reply With Quote
Old 05-14-2001, 10:41 AM
Posts: n/a
I still have not figured it out. Your description sounds the same as mine and like you, I can live with it but I would really like to know what it is. I have had the car since new and I do not remember it doing this until the last year or so. Nothing has ever been done to the a/c itself--not even added any R134. I did put a new belt a few months ago. It made the same sound before and after installing the new belt. I guess it could be the clutch but I really do not know how to trouble shoot it.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
300E misses with A/C on...Why??? mike690003 Tech Help 2 09-01-2003 04:45 PM
Replacing A/C Hose 1986 300E? zym57 Tech Help 2 03-18-2003 02:57 PM
MB or aftermarket A/C compressor? - 300E JFAZ Tech Help 2 01-17-2003 08:18 AM
a/c still working for no benefit on '86 300E can-do Tech Help 18 07-10-2002 11:31 PM
88 300E a/c and heat budman Tech Help 2 06-29-1999 09:56 PM

All times are GMT -4. The time now is 08:36 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page