Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-09-2006, 06:16 PM
johnqle's Avatar
Registered User
 
Join Date: Mar 2003
Posts: 10
E320 2001 stuck in EC mode + EB1419 faulty code

My E320 was stuck in EC mode (light on) and thus could not get AC to work.
I found several related topics explaining how to obtain the on-board diagnosis codes via N22 control module on benzworld.com and mercedesshop.com forums as well as http://www.continentalimports.com/ser_ic40142.html and http://www.eclassbenz.com/acdiag

01: 98 in-car temp
02: 76 outside temp
03: 69 heater-core temp left
04: 69 heater-core temp right
05: 73 evaporator temp sensor
06: 66 ECT sensor
07: 04 refrigerant pressure
08: 67 refrigerant temp sensor

I also got the following Faulty codes:

EB1419 electromagnetic clutch
EB1234 sun sensor (safe to ignore based on read articles)

I then followed the instructions posted by Sokoloff (MB bulletin 37/99-2) and could turn off the EC mode:
210 chassis climate control problem

I have not yet replaced the evaporator nor the refrigerant temperature sensor at this point. My AC is still not blowing cold air though.

The faulty electromagnetic clutch code EB1419 does not sound like a simple problem to me. So, before replacing any unnecessary parts, just wonder if any MB tech gurus here can point me to the right direction?

Appreciate much your inputs...
John

__________________
Tigger - 2001 E320
Reply With Quote
  #2  
Old 11-09-2006, 06:34 PM
Registered User
 
Join Date: Nov 2006
Posts: 5
check to see if low of freon and if not check ac preasure switch
Reply With Quote
  #3  
Old 11-09-2006, 06:35 PM
Registered User
 
Join Date: Nov 2006
Posts: 5
need to try and clear codes after repair sometime ac will not kick on
Reply With Quote
  #4  
Old 11-09-2006, 06:58 PM
johnqle's Avatar
Registered User
 
Join Date: Mar 2003
Posts: 10
Quote:
Originally Posted by MARK T View Post
need to try and clear codes after repair sometime ac will not kick on
Thanks. Is it something I can do to clear the codes or gotta take it to dealer?
__________________
Tigger - 2001 E320
Reply With Quote
  #5  
Old 11-10-2006, 12:27 AM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
Read stevebfl's article again. You can clear codes from the display.
__________________
Terry Allison
N. Calif. & Boca Chica, Panama

09' E320 Bluetec 77k (USA)
09' Hyundai Santa Fe Diesel 48k (S.A.)
Reply With Quote
  #6  
Old 11-11-2006, 12:10 AM
johnqle's Avatar
Registered User
 
Join Date: Mar 2003
Posts: 10
Terry,
Would you mind provide a link or thread ID? I searched and Stevebfl has posted like 500 threads total!
__________________
Tigger - 2001 E320
Reply With Quote
  #7  
Old 11-11-2006, 12:30 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
You need to check the clutch. Ensure that it has continuity by disconnecting the lead and checking the resistance to ground. Also ensure that you can turn the compressor input shaft by hand.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page