Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-15-2006, 06:30 PM
Registered User
 
Join Date: May 2005
Posts: 84
Question 190e runability

hi all,
1985 190e 2.3 8v, new cap rotor plugs fuel filter air filter, made a 200 mile trip yesterday, the further i drove the less power it had, barley made it over the pass 1300 foot elevation. has 190k on it have no service history. did a head gasket on it last year, had valves and guides checked and head surface ground( minor warp of .005). have not done compression check yet. when you free rev it you get a bad bog and will not rev over 4k at wide open throttle. could this be a sign of low fuel pressure? it misfires while driving under acceleration like a lean misfire. if you drive it easy it runs ok but still lacks power. steer me in the right direction. I do not have access to a fuel pressure gauge set up, may have to pay for a pressure test. can't afford to throw money at it. any suggestions?

Reply With Quote
  #2  
Old 12-19-2006, 08:40 AM
Registered User
 
Join Date: May 2005
Posts: 84
looks like the pre cats have gone bad and are plugged up, I will give an update after removal.
Reply With Quote
  #3  
Old 12-20-2006, 11:02 PM
1985 190e rebuilding fun
 
Join Date: Dec 2006
Location: Ventura, CA, USA, Earth
Posts: 9
I'm having a simular problem and have thrown $$$ at it. The entire fuel system has basically been replaced or rebuilt including the ECM, altitude sensor, fuel distributor, regulator, pump, EHA and idle control valve. I'm going to pull the air box tomorrow and check out what's going on under there. I've ordered a new air duct just cuz it's 22 years old. I'm also going to clean up the WOT switch. It shows 18Mohms when it should be infinite. The circuit does close at WOT as it should. I've ruled out anything to do with the fuel system and am now seeking a vacuum leak. Keep me updated on what you find.

gw 85 190e 2.3 8v
Reply With Quote
  #4  
Old 12-22-2006, 09:02 AM
Registered User
 
Join Date: May 2005
Posts: 84
pre cats fell apart and went down the pipe the the main cat. removed the front pipe and cat, cut the main cat off the pipe and cleaned all the material out of the main cat screen and cleared the pipe of all material. welded the cat back on and all is fine again, runs better now than is has in a long time.
Joe

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page