Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-21-2006, 10:31 AM
Registered User
 
Join Date: Nov 2006
Posts: 13
please help; need advice for a quick fix on a 300e

Hi, I have a 1987 300e with about 150k on it and this morning the car wouldnt start. It has been working fine for months but for some reason it wouldnt start today. I did have to replace the OVP relay once though. I jump started it with another car and the engine would turn off as soon as one of the cables were removed. Does anyone know what the problem is or what I should do? your help would be greatly appreciated. thanks

Reply With Quote
  #2  
Old 12-21-2006, 11:00 AM
GSMITH's Avatar
Registered User
 
Join Date: Aug 2004
Location: Palm Bay, Florida
Posts: 152
Sounds like the battery or altenator died

If you have a voltmeter check the battery should be around 12V with the car off. Batteries die in a couple of ways. They are usually made of 6 cells in series to get to 12V. The cells can die open or short. If a cell dies the voltage will drop 2V per cell. If you get 12V this indicates the altenator is the problem. They can become a resistive short across the battery and drain it overnight. Since you said that the car dies when you disconnect the jumper I think the altenator has gone bad but it is a lot easier to pull the battery and have it checked out first if you cannot do this yourself with the voltmeter.

Since you have replace the OVP check the fuse on top of it. Strange things happen when that fuse blows.
Reply With Quote
  #3  
Old 12-21-2006, 11:21 AM
Registered User
 
Join Date: Feb 2006
Location: Jasper, TX
Posts: 31
Exclamation

Sounds a lot like the alternator may be the culprit.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page