Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-26-2006, 07:06 PM
Registered User
 
Join Date: Dec 2006
Posts: 16
2001 c-240 oil prssure from oil filter just rebuilt

I Just Bebuilt The Entire Engine,I cranked the Engine To Get the Oil Pressure Going With Filter Off But Had No Oil Coming Up To the Oil Filter.I Turned it Over 1-3 Minutes With Starter Motor With The Plugs Out.I Want To Know If I Turn It Over Without Oil Coming Up into the Oil Filter housing.
Can I Start It Up With Plugs In Without Worrying about No Oil Coming Into The Filter.When I Put The Oil Pump In I Filled It Up With Oil And Put Back In The Pan Correctly,or Did I Forget To Push The Pipe Enough Into The Pump Where The Rubber Washer Goes After Screwing It In Its Place With The 3 Bolts.


Last edited by leinad; 12-26-2006 at 07:13 PM. Reason: correction
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page