Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-09-2001, 01:25 AM
Registered User
 
Join Date: Apr 2001
Location: marietta
Posts: 65
i bought a bosch oxygen sensor (part # 000 540 52 17) last year for my 95 c220 only to find out that this "oem" sensor has a different connector with the mb's. i have called many parts shop and they all told me this is the one for my car. fastlane did not display the part number. is there a seperate adapter i need to buy or this one i got from the mail was a wrong one in the right box? thanks
Reply With Quote
  #2  
Old 05-09-2001, 04:55 AM
David C Klasse's Avatar
CheFrac is Back!
 
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
There should be no adaptor.
I recently bought the exact same part. It is the 2nd O2 sensor, correct?
It should fit, unless it's different for the 220 as opposed to the 280, which could be the problem also! Make sure there is no difference.
And make sure that the sensor is for the rear, 2nd, and/or feedback sensor.
__________________
2006 E350 w/ 155k miles (Daily Driver)

Previous:
1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
  #3  
Old 05-09-2001, 02:18 PM
Registered User
 
Join Date: Apr 2001
Location: marietta
Posts: 65
thanks for the prompt response,
i found the oxygen sensor on the passenger side (not sure before or after the cat converter) when i jack up the car and i chase the wire to the passenger side of the engine compartment and found a large short round connector instead of the thin long connector on the bosch sensor. did i find the right sensor? thanks,i will look again this weekend
Reply With Quote
  #4  
Old 05-09-2001, 02:25 PM
David C Klasse's Avatar
CheFrac is Back!
 
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Apprentice.
I saw them install it, but can't be sure exactly.
It is on the passenger side, and you can see it on the side/top of something... I don't know what that is right there. It is under the car, about 1/2 in the middle of the front doors, if that made any sense.
The part you bought is specifically for Mercedes, correct?
And did you have the codes read? You're sure it's the 2nd O2 sensor, not the main one?
__________________
2006 E350 w/ 155k miles (Daily Driver)

Previous:
1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
  #5  
Old 05-11-2001, 09:14 PM
Registered User
 
Join Date: Apr 2001
Location: marietta
Posts: 65
i went to the dealer today and the part number they gave me were 000-540-65-17 and 001-540-01-17 and costing $139.00 and $156.00. i guess i sould just order from dealer next time to save all the headache. (i guess this means the bosch sensor i ordered was wrong?)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FAIL Emission Test andrew1413 Tech Help 20 04-05-2004 05:07 PM
bosch oxygen sensor for 95 e320 95e320 Tech Help 2 02-25-2003 03:13 PM
Oxygen Sensor Output - Negative Value??? jgl1 Tech Help 4 09-12-2002 09:37 AM
C220 Oxygen sensor question chandrab Tech Help 0 01-12-2002 05:57 PM
560sl Oxygen Sensor santora4 Tech Help 0 01-07-2002 12:28 PM



All times are GMT -4. The time now is 05:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page