Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-18-2007, 04:55 PM
Registered User
 
Join Date: Apr 2006
Location: Northern VA
Posts: 10
Is this normal

I have a 1996 S420 recently purchased. I notice that when I first start the car the oil light will stay on for about a block of driving before it goes out, but never comes back on. Also when idling the oil pressure drops to between 1 and 2, when I hit the gas to start driving again it goes back to close to 3. Is the oil pressure sensor bad?

Reply With Quote
  #2  
Old 01-18-2007, 09:49 PM
Hatterasguy's Avatar
Zero
 
Join Date: Nov 2002
Location: Milford, CT
Posts: 19,306
Well you have normal oil pressure, I am assuming you checked the oil to make sure its at the proper level.

On my W126 that is a low oil level light, there is a float in the pan with a delay that pops the light up when the level gets just past the min mark on the dipstick. To remind those of us that never check the oil to do so. Open up the manual that came with the car and see what that light means, I suspect it's similer to mine. If so first clean the connection at the sensor, if that doesn't do it then the float is probably bad.

The oil pressure guage is what matters, if it settles on 0 then you worry!
__________________
2020 GMC Sierra Denali
2007 Tiara 3200
Reply With Quote
  #3  
Old 01-19-2007, 05:44 PM
Registered User
 
Join Date: Sep 2004
Location: Las Vegas, NV
Posts: 685
If your car is parked at a steep angle in the driveway then the oil level sensor will think its low until you drive for a few seconds.
__________________
DS
87 300D latest project!
11 GLK 350 So far, so good
08 E350 4matic, Love it.
99 E320 too rusted, sold
87 260E Donated to Newgate School
www.Newgateschool.org - check it out.
12 Ford Escape, sold, forgotten
87 300D, sold, what a mistake
06 Passat 2.0T, PITA, sold

Las Vegas NV
Reply With Quote
  #4  
Old 01-19-2007, 06:08 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Do a Search on "Oil Tubes"

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page