Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-09-2001, 07:17 AM
Johnson Chan
Guest
 
Posts: n/a
Heres the deal with the 84 300D Turbo w/109,000 miles.

When driving, all of a sudden, the AC will blow out hot air, and then after a few minutes it will blow cold air again.

The blower works, and since the air coming out is pretty cold and works most of the time, I would think it has freon in it.

Any thoughts? maybe the compressor is going out? I would like to keep R12 in the system as long as possible (I like it because its cools better than R134a). Thanks.
Reply With Quote
  #2  
Old 05-09-2001, 07:35 AM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,776
sounds like

the compressor cycling. Is the system at the correct charge?
Jim
'85 300D
'95 E320
'97 CRV
Reply With Quote
  #3  
Old 05-09-2001, 08:25 AM
LarryBible
Guest
 
Posts: n/a
You need to check the monovalve and the climate control pushbutton unit. If it blows cold air part of the time, the problem is not refrigerant related, it is control or monovalve related.

Good luck,
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent A/C problem 260E mrbrokerman Tech Help 10 05-19-2006 08:13 PM
81 Mercedes 123 PARTS FOR SALE on EBAY cpapp Mercedes Used Parts For Sale & Wanted 6 01-21-2004 10:55 AM
560sel Aux Fan - A/C Problem moedip Tech Help 27 07-09-2003 12:31 PM
Shut Off And A/C Vacuum Problem Abner Mality Diesel Discussion 5 07-08-2003 06:25 PM
123 chassis taillight problem deeph8 Tech Help 1 10-31-2001 12:56 PM



All times are GMT -4. The time now is 05:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page