Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-31-2007, 02:35 PM
Registered User
 
Join Date: Sep 2000
Location: Minneapolis, MN USA
Posts: 341
1989 560 SEC seat belt won't latch

Hi all!

This morning I found the driver's seat belt won't click and latch anymore. Just moves in and out... Doesn't seem to be anything stuck in there and the red release button has normal travel...... Any suggestions?

Thanks...

-m

__________________
Now:
2014 Tesla Model S (320 miles)
1999 S500 Grand Edition 164k
1992 300D 2.5 Turbo 287k
2005 E320 4MATIC wagon
1991 Alfa Romeo 164L 99k (sleeping for a while)

Then: 96 Lincoln TC, 93 Lincoln TC, 87 560 SEL, 87 300 SDL, 80 300D, 89 560 SEC
Reply With Quote
  #2  
Old 01-31-2007, 07:41 PM
Registered User
 
Join Date: Aug 2006
Posts: 141
Seat belt won't latch

This is usually caused by debris in the latch, Try blowing it out with compressed air.Sheepskin seat covers are a major cause of this complaint.
Mike
Reply With Quote
  #3  
Old 02-10-2007, 03:10 PM
Registered User
 
Join Date: Sep 2000
Location: Minneapolis, MN USA
Posts: 341
No seat covers on this one... I tried the air trick today with no luck.

In closer comparison to the passenger side latch, when you press the release button the inner black piece moves with it. On the broken latch, the inner plastic piece does not move. I can move it manually by pressing it with a thin screwdriver, but it doesn't help. Seems kinda like something is broken internally.

Anyone have a spare, by chance?

-m

-m
__________________
Now:
2014 Tesla Model S (320 miles)
1999 S500 Grand Edition 164k
1992 300D 2.5 Turbo 287k
2005 E320 4MATIC wagon
1991 Alfa Romeo 164L 99k (sleeping for a while)

Then: 96 Lincoln TC, 93 Lincoln TC, 87 560 SEL, 87 300 SDL, 80 300D, 89 560 SEC
Reply With Quote
  #4  
Old 07-10-2007, 11:02 PM
Registered User
 
Join Date: Sep 2000
Location: Minneapolis, MN USA
Posts: 341
As a follow up, I bought a new seat belt latch (the part between the seat and the center console) and swapped it out. Works fine now!

-m

__________________
Now:
2014 Tesla Model S (320 miles)
1999 S500 Grand Edition 164k
1992 300D 2.5 Turbo 287k
2005 E320 4MATIC wagon
1991 Alfa Romeo 164L 99k (sleeping for a while)

Then: 96 Lincoln TC, 93 Lincoln TC, 87 560 SEL, 87 300 SDL, 80 300D, 89 560 SEC
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page