Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-07-2007, 01:25 PM
E150GT's Avatar
I'm a chicken
 
Join Date: Sep 2006
Location: SAN ANTONIO, TEXAS
Posts: 1,148
Headlamp Wipers

I know the little headlamp wipers are pretty useless and I've never used them on purpose, but I would like to see them work proplerly. My problem is that when I press in the wash system both the wipers work, but on the passenger side, the wiper stays wherever it was when I let go of the button while the driver side wiper goes back to its proper spot. Also is windshield wiper fluid supposed to spray on the headlamps too beacause they don't. Anyone ever had problems like this?

Reply With Quote
  #2  
Old 02-07-2007, 01:46 PM
BENZ-LGB's Avatar
Strong, silent type
 
Join Date: Apr 2001
Location: Southern California
Posts: 1,663
Quote:
Originally Posted by E150GT View Post
I know the little headlamp wipers are pretty useless and I've never used them on purpose, but I would like to see them work proplerly. My problem is that when I press in the wash system both the wipers work, but on the passenger side, the wiper stays wherever it was when I let go of the button while the driver side wiper goes back to its proper spot. Also is windshield wiper fluid supposed to spray on the headlamps too beacause they don't. Anyone ever had problems like this?
Which model and year Benz do you own?

1. Washer fluid is supposed to spary on the headlights. If yours doesn't, the pump may be bad or it may be clogged In the W124 series there are two pumps attached to the reservoir tank. One for the windshield and one for the headlights. Tracing the tubes will tell which one is which. The pump may be bad or it may be clogged. New pumps are fairly cheap.

2. If you flip the wiper arm down, there is a nut holding the arm to the motor spindle. Yours may be loose or the arm may need to be repositioned.

I got rid of my headlight wipers when I installed Euro lights in my 300TE. I will do the same (remove the wipers) when I install Euro lights in my 300CE.

Good luck!
__________________
Current Benzes

1989 300TE "Alice"
1990 300CE "Sam Spade"
1991 300CE "Beowulf" RIP (06.1991 - 10.10.2007)
1998 E320 "Orson"
2002 C320 Wagon "Molly Fox"

Res non semper sunt quae esse videntur

My Gallery

Not in this weather!
Reply With Quote
  #3  
Old 02-07-2007, 01:53 PM
E150GT's Avatar
I'm a chicken
 
Join Date: Sep 2006
Location: SAN ANTONIO, TEXAS
Posts: 1,148
1986 420 Sel

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page