Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-11-2007, 01:34 PM
Registered User
 
Join Date: May 2005
Posts: 2
E420 timing issue?

Having a problem with my 94 E420 w/192k on it. If it is not driven for a few days it will run fine for 10 minutes and then rough for 20+ before running fine again. This has been happening for months then the other day it ran so rough it actually died for the first time. Maybe just a coincidence but that was also the first time I noticed the outside temperature gauge kept climbing up to 100 degrees. I ran the car the next day and after idling rough for quite some time it ran fine and the outside temp gauge dropped immediately to the appropriate temp and the car has been fine since. Looking at the threads on this site my guess is a timing issue... thoughts? Thanks
Reply With Quote
  #2  
Old 02-11-2007, 04:13 PM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
You don't really mean outside temperature gauge do you? The outside temperature gauge shouldn't have anything to do with the operation of the engine. If the engine temperature gauge is behaving strangely that could hold a clue. That said, it doesn't sound to me like a timing issue. I would get the fault codes read for more clues.
Reply With Quote
  #3  
Old 02-22-2007, 02:46 PM
DRICHFL's Avatar
W124 Passion for E420
 
Join Date: May 2005
Location: Sunshine State
Posts: 225
I agree with Deanyel you must scan your module first before we can really help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page