Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-11-2007, 09:17 PM
Registered User
 
Join Date: Mar 2007
Posts: 4
E320

Can someone please help my car constantly hesitated then finnally stopped cranking. It sounds like it wants to crank but doesn't. We changed the fuel filter but it cranked and ran for a short time then quit.
Please someone help.
Reply With Quote
  #2  
Old 03-11-2007, 09:21 PM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
Tell us what car you have - there's lots of different E320s.
Reply With Quote
  #3  
Old 03-11-2007, 09:36 PM
Registered User
 
Join Date: Mar 2007
Posts: 4
E320 1999
Reply With Quote
  #4  
Old 03-11-2007, 09:37 PM
Registered User
 
Join Date: Mar 2007
Posts: 4
mercedes E320 1999
Reply With Quote
  #5  
Old 03-11-2007, 11:46 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
Did you check to see if you have a low voltage condition?

If my car won't crank, the first thing I check is the battery, alternator or voltage regulator.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #6  
Old 03-12-2007, 08:25 AM
Parrot of Doom's Avatar
1997 W210 E300TD 243,000
 
Join Date: Mar 2006
Location: Manchester, UK
Posts: 983
When you say 'cranking', do you mean the engine actually running?

Or do you mean cranking in it's correct useage, as the moment when the starter motor is turning the engine to get it to fire?

It sounds to me as though the engine was hesitent while running, then you changed the fuel filter, it ran for a moment and now won't run at all? And now the battery has been flattened, so it won't even crank?

I think you've not replaced the fuel filter correctly, its drawing air in instead of fuel, and you've flattened the battery.

Check your fuel filter installation (missing o-rings?), and recharge your battery.
Reply With Quote
  #7  
Old 03-14-2007, 01:26 AM
Registered User
 
Join Date: Mar 2007
Posts: 4
E320 1999 Mercedes battery is fully charged but no power at the fuel pump.
out 7 or 8 times pump may turn on only twice. turn ignition switch car cranks but will not start sounds as if it will but doesn't.
Reply With Quote
  #8  
Old 03-15-2007, 07:15 PM
skhagen's Avatar
Registered User
 
Join Date: Mar 2007
Location: Lexington
Posts: 82
check fuel pressure at the injector rail

check pressure with a simple dial gage at the injector rail and go from there.
Reply With Quote
  #9  
Old 03-15-2007, 10:38 PM
Parrot of Doom's Avatar
1997 W210 E300TD 243,000
 
Join Date: Mar 2006
Location: Manchester, UK
Posts: 983
Stick a meter across the fuel pump terminals and ensure continuity of supply.

I don't know what relay switches the fuel pump, but that would be my first port of call.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page