Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-12-2007, 11:49 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
01 CLK430 rag top issues

Already frustrated with the W124 head gasket issue, I now have a problem with the top operation on my W208.

The rollbar light flashes after starting the vehicle, and toggling the switch gets no up/down behavior from the rollbar/rear headrests. I can hear a "click" when the switch is actuated, but that's it.

With the rollbar inoperative, the soft top operation is halted beyond the windows lowering when the front of the top is unlatched. The top lowering switch just flashes slowly.

I believe the inactive rollbar mechanism has something to do with this. Are there any tips/tricks to troubleshooting this w/o specialized diagnostics?

__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #2  
Old 03-13-2007, 08:16 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Are the headrests UP or down?

IF they are up...try holding the headrest switch in the UP position for 25-30 seconds to lock the ram back in place.

AS far as diagnostics go you do need a scanner....!
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 03-13-2007, 06:42 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Headrests are down. They were operable at first even when the top didn't function, but eventually remained in the "down" position. I tried holding the switch in the "up" and "down" positions for nearly a minute each, but nothing happens.

Today I pulled the ground cable off the battery for about a half hour and reconnected to see if resetting the system would do anything. The rollbar switch still blinks when starting the car, and still no action. I did replace a blown 40-amp fuse in the rear fuse box that supposedly operates the soft top hydraulic system.

Bottom line is that everythig has remained the same. Looks like a trip to the dealer (as soon as I get the other ailing car back in my garage)...
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #4  
Old 04-27-2007, 10:31 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Back from shop...

...and a $2800 repair bill!!!

Actually, about $2100 was the repair (did overdue "B" service while there).

Hydraulic pump motor burned out...can't buy seperately. Had to get entire pump and motor ($1200) + $921 labor.

So I spent more to fix the top on the wife's car than the top-end rebuild on the W124! We're eating ketchup packets for a few months!

Wife was happy that her car was back...I was weirdly pissed at the car (out of warranty six months ago). I refused to tag along with her in the W208...
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #5  
Old 05-01-2007, 01:32 PM
Registered User
 
Join Date: Jan 2002
Location: England
Posts: 1,841
Well it's gotta be said, that sucks, bad luck. How's the roof mechanism on SLs and old W124 cabrios? I wonder if it's equally prone to failure or its jsut a 'new mercedes' marvel we're looking at.
__________________
190E's:
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
http://www.maylane.demon.co.uk/190esmall.jpghttp://www.maylane.demon.co.uk/190esmall2.jpg
Reply With Quote
  #6  
Old 05-01-2007, 02:17 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Her previous vehicle was a 1995 500SL (R129). Front top lock mechanisms eventually had to be replaced (common issue on these models), but at $120 each and easy replacement in the comfort of your own garage, not much of a hassle.

What I didn't like was the plastic rear window. Ours split in half six months after the car was purchased (used). Dealer didn't want to cough up any money, so I got in touch with the regional rep. They ended up paying for all but $200 of the repair.

Wife has owned a ragtop car of some sort since we've been married, but personally I find them troublesome (and expensive, when they are motorized)...

__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page