Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-23-2001, 06:20 PM
Registered User
Join Date: Dec 1999
Posts: 102
we took out the headlight bulb and part of the bulb is melted on ... some sort of short... what can i do??

none of the headlights work..

00 S500 W220
93 300SE W140
01 C 240 W203
86 SVO Mustang (Turbo Pwr'd.. hehe)
Reply With Quote
Old 05-23-2001, 08:31 PM
Johnson Chan
Posts: n/a
did you use overwatted bulbs or they OE?

You can try to rewire them with new wires and a sodering gun

or you can upgrade to euro lights. they are much better.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Aux Fans broke? / 92 300e 2.6 Miles81_240d Tech Help 5 04-23-2003 11:19 PM
300e 2.6 300CE Tech Help 0 03-18-2003 09:38 PM
Help! 92 300e 2.6 mechanical Q's Miles81_240d Tech Help 12 10-14-2002 04:07 PM
300E Power Seats donít work? Herb Franck Tech Help 6 12-03-2001 09:18 AM
Blower fan on 93 300E 2.6 BmwTek Tech Help 2 11-11-2001 11:34 AM

All times are GMT -4. The time now is 05:12 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page