Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-06-2007, 04:20 PM
Registered User
 
Join Date: Apr 2007
Posts: 1
Angry 2002 CLK320 Nagigation Problem

I have a new to me 2002 CLK 320 convertible. It came with pretty new navi cd's from 2005 (navteq). I put in the CD for my region (southwest) and it showed my car was in the pacific ocean. I set my location manually via an intersection and set my destination and headed out. Worked great for about 10 miles then went all wacky. It had me doing a U turn on the highway etc. Seemed like it lost it's mind!

I cancelled that route and on the main map screen noticed it said 00 SAT which I believe means that it is not getting any satellite reception. What do you think could be wrong? Is it that antenna or???? Where is that antenna and how can I check this thing out? Strange that it would work for 10 miles perfectly and then never again! HELP!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page