Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-12-2001, 03:41 PM
Registered User
Join Date: Nov 2000
Location: Knoxville, TN USA
Posts: 56
Pardon a stupid suggestion, There is no mention of number of miles on the clock. Could the condition of a high milage timing chain possibly be in question?
Just a thought.
Steve Short
'91 300SE sold
'92 190E 2.3 sold
'99 S420
'06 Mini Cooper S
'08 Triumph Rocket III
'02 CLK430
Reply With Quote
Old 06-12-2001, 10:17 PM
Senior Member
Join Date: Apr 2001
Location: Beech Island, S.C.
Posts: 468

Sound like cheap gas or timing problem. Have you had the cooling system pressure checked. Maybe coolant leaking into the combustion chamber
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
190e 2.3 pinging and timing ..... haasman Tech Help 7 01-09-2005 10:22 PM
C230 pinging? mpolli Tech Help 2 09-26-2004 05:29 PM
Rear suspension pinging noise Alan Hamm Diesel Discussion 2 03-24-2004 06:46 PM
300D engine question ( pinging ) mslipac Diesel Discussion 6 01-01-2004 08:40 PM
High Speed Pinging Sounds 85 300 Tdt shear2001 Diesel Discussion 7 12-28-2003 04:04 PM

All times are GMT -4. The time now is 03:16 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page