Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-23-2007, 04:48 PM
will70724's Avatar
Registered User
 
Join Date: Oct 2006
Location: vallejo ca.
Posts: 401
Coolant circulation pump bad??

I just tested the fault codes through the climate control testing way.


I got code e 151.. which I l ooked up and it says its the coolant circulation pump.. open or short circuit.

I always thought it was the blower regulator because of the little amount it blows through the front ( but not the back)

What is my next step to testing the coolant circulation pump?

Thanks in advance.

__________________



1992 SEL 600..... 143,000 miles
Reply With Quote
  #2  
Old 05-23-2007, 05:15 PM
Registered User
 
Join Date: Jul 2003
Location: Montreal, Quebec
Posts: 508
Coincidence, I'm working on the same problem.
I also presumed a bad coolant circulation pump. I tested it after removing it from the car and all test were OK doK. After putting it back, I still had the same problem. Time for a new coolant circulation pump.
Same problem with the new pump, so I have to look somewhere else.
After opening the old pump, I noticed a lot of rust around the electrical motor.
Maybe that rust prevented to pump to turn, although the electrical circuit appeared to be OK.
I'm told that a defective pump could destroy the climate control module, creating all sorts of problems.
Anyone with a suggestion or two????
Reply With Quote
  #3  
Old 05-23-2007, 05:19 PM
will70724's Avatar
Registered User
 
Join Date: Oct 2006
Location: vallejo ca.
Posts: 401
Yea I always thought it would of been the blower regulator since the rear ac/heater works good.

Wondering if the code I was given might read as a open or short circuited coolant pump but still be the blower regulator?

__________________



1992 SEL 600..... 143,000 miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page