Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-05-2001, 07:23 PM
migueli
Guest
 
Posts: n/a
on my 91' 500SL when i turn the a/c on for the first time in the day the compressor always start,but after the engine reach the normal operating temp. and I turn off the car the a/c compressor will not engage after restarting the car like 15 min later but if I turn it off again and restart the car the compressor will engage. can anybody please give me some ideas. thanks.
Reply With Quote
  #2  
Old 06-05-2001, 08:34 PM
Registered User
 
Join Date: Dec 2000
Posts: 368

Start by checking the engine belt. If it's loose replace it (I think yours has the automatic tensioner), if it's manual try tightening the belt.
Your car has a speed sensor on the compressor. If the engine RPM doesn't match the compressor speed signal it cuts off via KLIMA relay.

If that doesn't work you should check resistance of evaporator temperature sensor. This sensor sends a signal to the compressor according to temperature to avoid freezing.
The sensor is located above the driver's side AC drain.
Resistance below 2.5k ohms is a faulty sensor.



Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
R129 500SL Climate Control Auto Mode and A/C longevity warren128 Tech Help 2 12-09-2003 03:32 PM
500SL A/C problem? 500sl SL Forum 0 06-18-2003 06:32 PM
Still trying to get a/c compressor to engage and still 1 KLIMA question Ron Brooks Tech Help 10 09-18-2002 03:39 PM
A/C Compressor Won't Engage '88 420SEL mscotta Tech Help 4 12-05-2001 11:05 AM
91 500SL A/C Compressor will not Engage migueli Tech Help 2 04-12-2001 09:00 PM



All times are GMT -4. The time now is 02:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page