Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-06-2001, 02:57 PM
Posts: n/a
After I shut off my car( '95 C280) you can hear the water going back in the reserve with pressure(bubbles). this causes the water to leak from the small pipe on the top side of the reserve. I don't know weather it's the thermostate, or water pump. Car doesn't overheat.

I have to fill it up with water every 3 days.

Thanks Harold
Reply With Quote
Old 06-06-2001, 03:04 PM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
I could very well be wrong on this one... but...

Are you talking about the hose that runs from the coolant reservoir (from the top of it) and over the radiator?
Have you tried tightening the hose where it meets the reservoir? It sounds as if air is getting into the system, therefore the bubbles and the leak.
Have you done this? I would try tightening the hose, I think it can be done with a screwdriver.

Any other ideas?
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 06-06-2001, 09:28 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I would installl a new clamp on the end of that hose where the leak is. Then a new cap for safe measure.
Donnie Drummonds
Reply With Quote
Old 06-07-2001, 02:13 PM
Posts: n/a
It was the thermostate, I changed that as well as th cap. Car's water doesn't leak anymore
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
96 C280 Water Pump countman Tech Help 3 05-26-2012 11:15 AM
water pump problem on 560sl? sms Tech Help 0 07-02-2004 11:44 PM
Radiator blew up Scott98 Diesel Discussion 15 02-24-2004 07:57 PM
Water problem! TROVERMAN Tech Help 2 11-25-2003 12:42 PM
1995 C280 Water Temperature Gauge Robert C. Eberhardt Tech Help 3 02-18-2002 03:11 PM

All times are GMT -4. The time now is 03:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page