Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-31-2007, 07:30 PM
Sid The Kid's Avatar
Registered User
 
Join Date: Dec 2003
Posts: 92
PSE help

Update on 1999 SLK230 thread

I bought the pse module and plugged it in today.......but it didnt work , now my wife is mad I spent 800 on it. The alarm still goes off when i plug in the battery...what else could this be? is there a special way of plugging it on..or would teh wrong batter also cause this problem? since i also bought a new battery
Reply With Quote
  #2  
Old 05-31-2007, 07:31 PM
Sid The Kid's Avatar
Registered User
 
Join Date: Dec 2003
Posts: 92
oh another thing...the module has a diff part number on it
Reply With Quote
  #3  
Old 05-31-2007, 08:21 PM
Carson357's Avatar
www.stonebrew.com
 
Join Date: Aug 2006
Location: San Diego, California
Posts: 1,114
what part number is old? new? where did you buy the pump? what was the main issue that caused the pump to be suspect?
__________________
1967 250 S
1967 280SE
1968 250S
1971 280 SE
1973 220
1974 280 S
1975 450 SEL
1976 220 D
1979 300SD
1983 300 SD
1985 230 TE euro
1986 280SL
1986 500 SEL euro
1986 190E 2.3
1990 300 SE
2003 C230 K
2004 C230 K
1987 560SEL
1987 300SDL now in canada
2005 C230
1998 C43 AMG Sold to DON
1993 190E 2.6
300TD Former daily driver Totaled
current:
R320 CDI
Ram 2500 Cummins
Reply With Quote
  #4  
Old 05-31-2007, 08:40 PM
Sid The Kid's Avatar
Registered User
 
Join Date: Dec 2003
Posts: 92
well I called the dealership and they said this part number is an upchange from the old part number so it shoudl work.
all the symptoms are the same when i try to start the car except now the lights dont flash with the alarm anymore.
i really dont know what to do....what else could it be besides the module?
Reply With Quote
  #5  
Old 05-31-2007, 08:40 PM
Sid The Kid's Avatar
Registered User
 
Join Date: Dec 2003
Posts: 92
the one that ends with 448 is the old one
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page