Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-25-2007, 05:54 PM
SK420SEL
Guest
 
Posts: n/a
car wont start

I have a 86 420sel, that will not start. Was driving home and it just quit. The fuel pump seems to be working, and it has spark but will not fire up. When you try to start it, it sounds like the timing chain is making noise? Scared to take it to a MB dealer
Does anybody have any ideas?

thanks
kris


Reply With Quote
  #2  
Old 06-25-2007, 08:37 PM
just-n-time's Avatar
Registered User
 
Join Date: Feb 2006
Location: Louisiana266 Maloy Rd winnfield71483
Posts: 804
Pull cam and valve cover to confirm that the chain has to much play, and look into the chain tensioner, hopefully it will be the later and you did not mess up the valves.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page