Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-12-2001, 12:45 PM
Posts: n/a
I've an '87 300 SDL that I bought recently that appears to have some A/C problems. The shop I bought the car from has been great, but I feel bad about taking the vehicle back several times after they have put several (probably expensive) parts in it to no avail.

The air conditioning works fine until the car has been running 30 minutes or so, then warm (heated) air starts to come from the vents. Turning the thermostat down a little fixes the problem for awhile, put before long the heated air shows up, and you are cooling the car too much to prevent the heat from coming on.

If this isn't odd enough, the warm air only goes to the front driver/passenger. The register in the rear sends out cooled air regardless.

A new pushbutton/thermostat wheen has been installed, I think an A/C relay, still no help. Any ideas out there?

Reply With Quote
Old 06-12-2001, 04:25 PM
G-Benz's Avatar
Razorback Soccer Dad
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Welcome to the forum!

I'm no expert in this area, but I've seen some threads with the same complaint.

Try a search on A/C or air conditioning, or vents, etc. Perhaps the solutions outlined on those posts will also rectify your problem.

Good Luck!
2009 ML350 (84K) - Family vehicle
2001 CLK430 Cabriolet (71K) - Wife's car
2005 BMW 645CI (124K) - My daily driver
2012 Mustang V6 (60K) - Daughter's car
Reply With Quote
Old 06-13-2001, 06:11 AM
Registered User
Join Date: Aug 2000
Posts: 269
One cause of unstable ACC temperature control in a W126 is a deteriorated Aspirator tube. This tube runs behind the glove box liner and pulls air through the temperature sensor (located behind the small grate in front of rearview mirror) With the AC running hold a small piece of tissue paper in front of the grate,it should be drawn against the grate. If not replace the tube with small AC line insulation (black foam tube)available at most home improvement stores.

Bob D.
Reply With Quote
Old 06-14-2001, 12:22 AM
Registered User
Join Date: Dec 2000
Location: ny
Posts: 119
i wold aso test the monovalve to see if functioning correctly.maybe it is not closing giving you heat all the time

just my.02
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
w126 erratic A/C mbtjc Tech Help 14 09-27-2004 11:39 PM
fuel odor through A/C in a W126 fredsegal Tech Help 1 09-02-2003 07:00 PM
A/C overhaul in 97 C230--Advice/Help needed rpmillie Tech Help 4 06-26-2002 12:42 PM
A/C on and my car is boiling hot?? Holson Adi Diesel Discussion 5 05-25-2002 06:03 PM
A/C Charging Problems on W126 Kelly Pepper Tech Help 4 07-09-2001 05:50 PM

All times are GMT -4. The time now is 06:18 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page