Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-04-2007, 01:25 AM
Registered User
 
Join Date: Dec 2006
Location: Colombia
Posts: 194
Oil pressure gauge bouncing and no reverse ligts. Help please.

Hi,

The oil pressure gauge on my 95 320E (W124) was bouncing constantly from 0 to 3 bar. The neadle was jumping all the time like crazy. So, I replaced the pressure sender and nothing happend. The gauge keeps jumping like crazy. Could it be an electrical problem inside the cluster or is it related with a real problem in the oil pump? The car runs perfectly and sounds just normal all the time. The oil and filter were replaced recently. BTW, I'm now thinking that the gauge problem started after that oil change. Is it possible that something went wrong during filter replacement?

The other thing is that I asked my mechanic to replace the neutral safety switch last week and now the reverse light are dead. Is it easy to track before taking the car to the shop again?

Thanks for your imputs.
__________________
-----------------
Juan
1995 E320 Sedan
2008 Ford Escape
RC Helicopter
Reply With Quote
  #2  
Old 07-04-2007, 02:09 PM
Registered User
 
Join Date: Dec 2006
Location: Colombia
Posts: 194
I went to the shop.

I visited my mechanic today and this is what he found:

Reverse ligts: it was something with the conection in the neutral safety switch, that he replaced a couple of weeks ago. He adjusted the connector and ligts are ok now. Easy.

Oil pressure gauge: since I already replaced the pressure sender, and the car is running perfectly, he told me it is surly an electrical problem. After looking under the hood, he found a cable (close to the oil filter) totally toasted because age. I already replaced the wire harness on this car but this is another cable or harness that needs to be fixed. Do you know a part description or number for this cables? I'll try to take a picture later.

Thanks,
__________________
-----------------
Juan
1995 E320 Sedan
2008 Ford Escape
RC Helicopter
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page