Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-15-2001, 09:25 AM
Registered User
Join Date: Mar 2000
Location: Mableton, Georgia
Posts: 9
I found out the bulb is missing from the dash light of my 1984 380SL (which I've owned for 15 months). My first reaction was to assume the worst, but I've seen a couple of threads mentioning that certain years were required to have the sensor light turn on at a set number of miles due to government mandate. When I tried putting a bulb in the light did go on- The car has 92k on it. Was '84 one of the years where it was appropriate to have the bulb pulled? Thanks in advance!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
My DIY Notes from Ignition Tumbler Cylinder Changing on 380SL ericgr Tech Help 0 10-22-2004 03:36 PM
84 380SL Wheels Sieb Wheels & Tires 9 08-22-2003 10:47 PM
380SL Lambda Location 61220SE Tech Help 3 08-17-2003 08:53 PM
What to look for in a 380SL? ncarter Tech Help 4 04-04-2000 12:38 AM

All times are GMT -4. The time now is 12:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page