Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-01-2007, 10:19 PM
MB-Dude's Avatar
Proud MB Owner
 
Join Date: Jul 2007
Location: Round Rock, TX
Posts: 215
Question Failing EGR Valve?

At idle or low RPM's, hot or cold, dead-stop or creeping forward, my '96 SL600 has developed a rapidly pulsing 'thump' sound on the right-hand side of the engine; not in the front of the engine, but on the right side. It is not metallic (as if a rod or valve train issue), but instead sounds pneumatic. The thumping sound has slowly been getting worse. Car performs wonderfully, but the thumping noise is now noticeable and... speaking frankly... is a little embarrassing. Could this be the RH side EGR Valve starting to fail?
__________________
MBCA Member #B012089 (Lone Star Section)
OBK Member #47 (W123 Division)
'96 SL600 (105K) Triple Black - Mein über-Fräulein
'79 240D (292K) Yellow/Saddle - Mein Spielzeug
'01 ML430 (123K) Black/Saddle - Wife's Ride
'94 SL500 (164K) Green/Champagne - Daughter's Dream
'73 450SL - RIP
'86 300E - RIP
'88 420SEL - SOLD
'94 S320 - SOLD
Reply With Quote
  #2  
Old 08-02-2007, 10:57 AM
Registered User
 
Join Date: Feb 2003
Location: Ontario, Canada
Posts: 3,160
Motormount?
__________________
2007 C 230 Sport.
Reply With Quote
  #3  
Old 08-02-2007, 12:14 PM
MB-Dude's Avatar
Proud MB Owner
 
Join Date: Jul 2007
Location: Round Rock, TX
Posts: 215
Quote:
Originally Posted by manny View Post
Motormount?
Hmmm.... Could be - on the V12, the EGR Valve is directly over the RH side mount. However, I do not seem to have any other symptoms of motor mount movement and the engine at idle is very stable and smooth. Will check it out, though. Thanks!

Any other ideas? Is there a test procedure for the EGR Valve?
__________________
MBCA Member #B012089 (Lone Star Section)
OBK Member #47 (W123 Division)
'96 SL600 (105K) Triple Black - Mein über-Fräulein
'79 240D (292K) Yellow/Saddle - Mein Spielzeug
'01 ML430 (123K) Black/Saddle - Wife's Ride
'94 SL500 (164K) Green/Champagne - Daughter's Dream
'73 450SL - RIP
'86 300E - RIP
'88 420SEL - SOLD
'94 S320 - SOLD
Reply With Quote
  #4  
Old 08-02-2007, 12:32 PM
Registered User
 
Join Date: Feb 2003
Location: Ontario, Canada
Posts: 3,160
If the engine is running smooth, I would'nt think it's an EGR valve problem.
Does your car have a Monovalve in the heating cicuit?
The have been known to make some strange, thumping noises, when the're opening & closing rapidly.
__________________
2007 C 230 Sport.
Reply With Quote
  #5  
Old 10-26-2007, 04:17 PM
MB-Dude's Avatar
Proud MB Owner
 
Join Date: Jul 2007
Location: Round Rock, TX
Posts: 215
Mystery Solved!

To close on this one, the attached picture shows the disconnected vacuum line from ??? to a solenoid valve that feeds directly into the RH Throttle Actuator of the V12. The yellow pencil points out the disconnection. The 'thumping' sound was air being drawn in whenever the solenoid valve opened. As I noted above, the 'thumping’ was very regular and not timed to engine speed. I have no idea what the purpose of this solenoid valve is, and would appreciate it if anyone could enlighten me.

The '96 SL600 ran well with the line disconnected, and only a little better (smoother idle, mainly) after reconnection of the vacuum line. Of course, this makes sense being connected to the intake manifold. I found this out of frustration... just let the engine idle and kept poking around until I found something - perseverance!

Cheers,
Jeff
Attached Thumbnails
Failing EGR Valve?-pa260003.jpg  
__________________
MBCA Member #B012089 (Lone Star Section)
OBK Member #47 (W123 Division)
'96 SL600 (105K) Triple Black - Mein über-Fräulein
'79 240D (292K) Yellow/Saddle - Mein Spielzeug
'01 ML430 (123K) Black/Saddle - Wife's Ride
'94 SL500 (164K) Green/Champagne - Daughter's Dream
'73 450SL - RIP
'86 300E - RIP
'88 420SEL - SOLD
'94 S320 - SOLD
Reply With Quote
  #6  
Old 10-26-2007, 06:51 PM
Registered User
 
Join Date: Jan 2002
Location: NY
Posts: 497
Looks like purge valve for charcoal canister. M120 has two of them. The other one is on the driver side.
Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page