Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-05-2007, 01:17 PM
Registered User
 
Join Date: Apr 2006
Posts: 23
Unhappy ASR Light 1994 S420

Dear Expert,
My car ASR light comes (yellow light, not RED one) up and the car goes to the limp mode. The service engine is also on and the faulty code 6 (Idle speed control inoperative, test electronic accelerator). I have to turn off the car and restart again, sometimes it happens 3-4 times in 5 minutes. The car is about 70K miles or 116k km.
After search for ASR light, especially reading Jim webpage I have the feeling that the Electronic Throttle Actuator is worn out.
I have changed the harness and stop lamp switch but it does not seem to help. I talked to a MB dealer in the part department and he gave me the price of the piece is CAN $2000.00. Pretty expensive eh? I also asked him whether you sell this part alot? He said at least in one year, he did not sell any (checked from his computer).
The question I want to ask is: Is this ETA the problem? or MAF Sensor or the rear speed sensors? (2 rear speed sensors each one is $311.00).

Any help would be much appreciated.

Reply With Quote
  #2  
Old 09-05-2007, 01:55 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
First check is tire sizing/ equal PSI
Reply With Quote
  #3  
Old 09-05-2007, 02:08 PM
zcc's Avatar
zcc zcc is offline
Registered User
 
Join Date: Nov 2005
Location: Kuwait
Posts: 610
I will first check the MAF wiring harness. Also it could be ETA or MAF Sensor or both in rare cases.
__________________
Master Computer Engineer, A+, Network+, MCP/MCSA/MCSE 4/2k/2k3 - Messaging, MCTS, MCITP, MCT, Brainbench, ICDL and starting Ph.D

380SE 1984 <------- Totaled by flipping accident
300SE 1988 <------- Sold
Volvo S70 2000 <---- 4 family
Opel Omega 2002 <-- 4 family
560SEC 1989 <------ Sold
560SEL 1990 <------ Sold
560SEL 1991 <------ 4 my mother
560SEL 1989 <------ Sold
600SEL 1992 <------ Current


http://search.ebay.com/_W0QQsassZkhazenzcc
Reply With Quote
  #4  
Old 09-05-2007, 02:12 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
You need to have the codes read from the EA/CC/ISC computer.

Also look at Arthur D's post on tire circumference, even tires 1/4" shorter on the rear can create problems.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #5  
Old 09-07-2007, 08:29 AM
pcmaher's Avatar
Big Black V12
 
Join Date: Apr 2003
Location: Chicago, IL
Posts: 430
http://v12uberalles.com/MAF_rewire.htm

http://v12uberalles.com/throttle_actuator_rewire.htm
__________________
1995 S600, 1 of 618 (sold)

"Speed is just a question of money...how fast you wanna go?"

LONG LIVE THE W140!
Visit my Web Page at www.v12uberalles.com
Reply With Quote
  #6  
Old 09-20-2007, 10:15 AM
Registered User
 
Join Date: Apr 2006
Posts: 23
Smile

Dear Friends/Experts,

I would like to update all of you about my ASR light status.
A week ago (Tuesday last week), after a raining day, I went home after work
my car went to limp mode for about 10 times in busy Ottawa, Canada downtown. I was so shameful. I let the car running for about 15 minutes then be able to drive home. I would guess the electrical short somewhere in the ETA, so I decide to open this up... and see what is inside. When this ETA is opened, I see all the wires insulation (11 of them) are in such bad shape crack, oxide (change color to green), when I touch them, they just turn to dust. All the wires are garbage from the IC board to the connector (about 2 meters or 6 feet long). So I just replace all the wires and the car seems to be OK now. I'm waiting for another raining day to see whether it will happen again or not (I hope not).
If some one's ASR light on and go to limp mode, I would suggest you open the wire bundle cover (by cutting it along the wire) to inspect the wire insulation inside before you open ETA (open the ETA is not an easy job).

I would like to thank all of the friends/experts who made all the ASR problem information accessible and this is the best forum I ever learn.
Reply With Quote
  #7  
Old 09-27-2007, 10:03 AM
Registered User
 
Join Date: Apr 2006
Posts: 23
New update:
After 2 raining days, my car works perfectly.
This means the wiring of the ETA was problem in my case.
Not all problem of the ETA is wiring, check Jim webpage, alot of information there.
Reply With Quote
  #8  
Old 09-27-2007, 10:17 AM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,933
Congrats dinh . . . your repair of the 'biodegrable' wires on your ETA is truly amazing.

Glad you got it fixed and I'm sure you're extremely !
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
  #9  
Old 09-27-2007, 11:45 AM
Registered User
 
Join Date: Apr 2006
Posts: 23
Smile

Hi All,

After I read the information on Jim's webpage and the web, it can be two possibilities: wire insulation and/or the reference potentiometer of the ETA. I just rewire to see whether it helps. I also have plan B to buy the new/rebuilt ETA. After google the web to see the availability/price. One company seems to be very good knowledge of the ETA and it is: http://www.jaytanindustriesinc.com/MercedesBenzTB.htm
I ask the guys how they rebuilt, here is what they email me:

Hi-Hi, Mr. Tran,

Our remanufacturing process,concentrates on four distinct areas to insure you are
purchasing a,"AAA" unit in both quality and value.

1. POTENTIONOMETERS "A" & "B"
a. The values of each of the four black traces on each potentiometer must
equal a pre set value.
b. Example: if potentiometer "A" value is x and "B" value is y then the addition of
the two must equal the value y. "A" tells the ECU how much the throttle plate
is OPEN "B" tells the ECU how much the throttle plate is CLOSED.
2. STEPPER MOTOR
a. The integrity of the motor to actuate movement of the throttle plate.
3. ELECTRONICS
a. Ribbon cable, IC board and wiring harness for opens, shorts and
potentiometer weakness failures.
b. Throttle valve switch which confirms with the ECU, the open or closed position
of the throttle plate.

4 MECHANICAL
a. Linkage, bearings, throttle plate and shaft for binding, sticking and hesitation

Finally, we make the unit look pretty. Is pretty a good word for an auto part?

Each of the four areas are certified OK, repaired or replaced as required.
The electronic throttle body is warranted for 2 years no mileage limit.

Please, feel free to contact us with any further questions or needed assistance which we may extend to you, our client.

Terry O'Connor

I hope the information that I post would help any one who has the same problem as I do.

Cheers,
Reply With Quote
  #10  
Old 09-27-2007, 12:37 PM
Registered User
 
Join Date: Nov 2003
Location: MD
Posts: 102
good price..?

I looked at the website and their prices are a lot better than I was quoted via Beckmann. They have my ETA's now and have not heard anything yet. If my units are both shot, I will pay for the testing and just get a set from these people. Iam talking 2450$ or 800$ for the same thing. What do you think Jim..?
Reply With Quote
  #11  
Old 09-27-2007, 05:49 PM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,933
Quote:
Originally Posted by dinh_hai_tran View Post
One company seems to be very good knowledge of the ETA and it is: http://www.jaytanindustriesinc.com/MercedesBenzTB.htm
I ask the guys how they rebuilt, here is what they email me:
Tnx for sharing the new site for Fuel Dist and ETAs.

lesrrt, I guess you can only know after you try their ETAs. Let us know. . .

__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page