Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-27-2001, 12:27 AM
Registered User
Join Date: May 2001
Location: Florida
Posts: 1,105
ON my 1983 300Sd, i was installing the power headreast toggle switch into my center console(got newer w126 seats) and in the process ended up taking apart the center console, as well as the area around the acc. After re-assembling everything the interior lights will not light up. All of the fuses under the bonnet appear to be OK. After letting the car sit for about 1/2 hour i went out and turned the lights on, and they lit up. 10 minutes later went out again to double check it was ok and to take it for a ride, and again my Interior lights were gone. Every single one of them except the dome light, guage cluster, center console, acc etc etc. all "dome" type lights work though, as well as all of my windows etc. I'm thinking possibly a ground wire? thanks in advance
Reply With Quote
Old 06-27-2001, 12:57 AM
Join Date: Jan 2000
Location: Indpls.,IN. USA
Posts: 84
The most likely culprit is the rheostat in the instrument cluster. Over time these oxidize and come and go until replaced. Move it back and forth 20 or 30 times and it may help.
Good Luck
Reply With Quote
Old 06-27-2001, 01:20 AM
Senior Member
Join Date: Apr 2001
Location: Beech Island, S.C.
Posts: 468
The lights on your console (antenna, rear dome light swith etc.) are lit by fiber optics. When you removed the console or the wooden panel for the switches you could have unplugged the fiber optical connection somewhere or you might just have a burned out bulb. Right behind the climate control pushbutton unit there is a junction with 1 bulb and about 5 fiber optic connections. Check that first.
Reply With Quote
Old 06-27-2001, 12:43 PM
Registered User
Join Date: May 2001
Location: Florida
Posts: 1,105
no, it's not the fiber optic cables because none of the lights work. The guages dont' light up, nor do the window switches. IF it were the fiber optic light then the only lights out would be the shifter selector, and teh buttons. Thanks though
Reply With Quote
Old 07-02-2001, 06:27 PM
MBenzNL's Avatar
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
There has to be a connection point under the dash/behind the center console panel that connect a couple of interior light related wires...did you have something connected to this (like the wire for illuminating the newly installed switch) or can the connection be released in any other way?
Normally this is a connection with a couple of (gray/blue) wires bolted to one isolated point...

1990 300SL-24
1993 C250D
with a minor 600+k kilometer
(the Netherlands)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W126 420SEL euro head light installation. afmcorp Tech Help 11 03-02-2005 11:57 AM
WTB: complete tan 3rd brake light (W126) James L Mercedes Used Parts For Sale & Wanted 0 10-26-2004 11:35 AM
W126 Door Light Switch Trouble jcantor Tech Help 4 09-13-2004 10:22 PM
W126 oil light 5banger Tech Help 7 02-20-2001 10:21 AM
w126 SRS light unkl300d Tech Help 1 07-02-2000 08:17 AM

All times are GMT -4. The time now is 10:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page