Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-27-2001, 03:12 AM
Village Idiot
Guest
 
Posts: n/a
I keep blowing the tach and electric fan fuses on my 85 16V. Does anyone know how I find out what is causing this and how I can fix it?
Any advice would be greatly appreciated.

mrossipir@yahoo.com
Reply With Quote
  #2  
Old 06-27-2001, 10:26 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You may have too low a resistance in the fan electro-magnet. You should check its current draw and replace if needed.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auxillary fan Kodiak Tech Help 3 08-07-2001 01:38 PM
Temp and fuse problems 190E Kodiak Tech Help 3 07-02-2001 12:48 PM



All times are GMT -4. The time now is 11:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page